summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/janino/janino-2.7.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/janino/janino-2.7.0.ebuild')
-rw-r--r--dev-java/janino/janino-2.7.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/janino/janino-2.7.0.ebuild b/dev-java/janino/janino-2.7.0.ebuild
new file mode 100644
index 000000000000..0942a3bb502e
--- /dev/null
+++ b/dev-java/janino/janino-2.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="An embedded compiler for run-time compilation purposes"
+HOMEPAGE="http://janino.net/"
+SRC_URI="http://janino.net/download/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/ant-core:0
+ dev-java/unkrig-nullanalysis:0"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="ant-core,unkrig-nullanalysis"
+
+java_prepare() {
+ unzip "${S}"/janino-src.zip -d ${JAVA_SRC_DIR} && \
+ unzip "${S}"/commons-compiler-src.zip -d ${JAVA_SRC_DIR} || die
+ find -iname '*.jar' -delete || die
+
+ mkdir -p target/classes && \
+ mv src/org.codehaus.commons.compiler.properties target/classes || die
+
+ mkdir examples || die
+ mv src/org/codehaus/commons/compiler/samples/* examples/ || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples examples/
+}