summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jchardet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jchardet')
-rw-r--r--dev-java/jchardet/Manifest1
-rw-r--r--dev-java/jchardet/files/build.xml19
-rw-r--r--dev-java/jchardet/jchardet-1.1.ebuild38
-rw-r--r--dev-java/jchardet/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/jchardet/Manifest b/dev-java/jchardet/Manifest
new file mode 100644
index 000000000000..89868b0ca8b8
--- /dev/null
+++ b/dev-java/jchardet/Manifest
@@ -0,0 +1 @@
+DIST jchardet-1.1.zip 82782 SHA256 2d83cd7a24a5a5c1cbf02f649008b0d792f5e4bc11e18a7df8ce4f885bc8650a SHA512 3a6141b1783286adfc072075f46da8f6e719361425cb2cbcd1c4c4dd82a6ef834a9f6f1aad8126d663dcfa12ad20cc362566dc2095ea95e01bd95adfae20bc28 WHIRLPOOL 4dbc0af21024b9da7d332cd2cb6c9103300a2618b189e4cbe97ad574b328db4727db60ec008f0c09b316d1d27c68371a33645d6a4dd1703f6cd906af3376dff4
diff --git a/dev-java/jchardet/files/build.xml b/dev-java/jchardet/files/build.xml
new file mode 100644
index 000000000000..ad0d4b0c1d09
--- /dev/null
+++ b/dev-java/jchardet/files/build.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0"?>
+<project name="htmlparser" default="jar">
+ <path id="build.classpath">
+ <fileset dir="lib/">
+ <include name="*.jar"/>
+ </fileset>
+ </path>
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac srcdir="src" destdir="build" classpathref="build.classpath"/>
+ </target>
+ <target name="jar" depends="compile">
+ <jar destfile="htmlparser.jar" basedir="build"/>
+ </target>
+ <target name="javadoc" depends="compile">
+ <mkdir dir="docs"/>
+ <javadoc sourcepath="src" destdir="docs" classpathref="build.classpath"/>
+ </target>
+</project>
diff --git a/dev-java/jchardet/jchardet-1.1.ebuild b/dev-java/jchardet/jchardet-1.1.ebuild
new file mode 100644
index 000000000000..779b386613f3
--- /dev/null
+++ b/dev-java/jchardet/jchardet-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of Mozilla's Automatic Charset Detection algorithm"
+HOMEPAGE="http://jchardet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.zip"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+EANT_BUILD_TARGET="dist"
+
+src_prepare() {
+ rm -f dist/lib/chardet.jar
+
+ mkdir -p src/org/mozilla/intl/chardet/ || die
+ mv src/*.java src/org/mozilla/intl/chardet || die
+}
+
+src_install() {
+ java-pkg_dojar dist/lib/chardet.jar
+
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jchardet/metadata.xml b/dev-java/jchardet/metadata.xml
new file mode 100644
index 000000000000..636867dbfc6b
--- /dev/null
+++ b/dev-java/jchardet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jchardet</remote-id>
+ </upstream>
+</pkgmetadata>