summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jcifs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jcifs')
-rw-r--r--dev-java/jcifs/Manifest1
-rw-r--r--dev-java/jcifs/files/1.3.17-build.xml.patch12
-rw-r--r--dev-java/jcifs/jcifs-1.3.17-r1.ebuild41
-rw-r--r--dev-java/jcifs/metadata.xml15
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-java/jcifs/Manifest b/dev-java/jcifs/Manifest
new file mode 100644
index 000000000000..b9c081bde3d5
--- /dev/null
+++ b/dev-java/jcifs/Manifest
@@ -0,0 +1 @@
+DIST jcifs-1.3.17.tgz 862091 SHA256 b6c5d82ed0bc015986206101a908eacd96bca8915187a092e34ebb373eeb545d SHA512 2fa1950f9ab6f0f3d45fd9b7866cc94993d1135f48d78ce357dca1d872746d22bff6097da8c418d0d11fd71d86b3fdc79b23195bcbab5bc460d8d0cca87efedc WHIRLPOOL eff4a90de687ac21525b9502a85e1b75a29856b46586020f929d46e2a8157c6f6c602fa3d848456ff864b22c2c2c603e34c193afea2cd03433dae74d5a4b1fea
diff --git a/dev-java/jcifs/files/1.3.17-build.xml.patch b/dev-java/jcifs/files/1.3.17-build.xml.patch
new file mode 100644
index 000000000000..e90c6ef0ace0
--- /dev/null
+++ b/dev-java/jcifs/files/1.3.17-build.xml.patch
@@ -0,0 +1,12 @@
+--- a/build.xml
++++ b/build.xml
+@@ -52,8 +52,6 @@ dependencies: Checks that all class dependencies are met.
+ source="1.5"
+ target="1.5"
+ fork="yes"
+- executable="/usr/local/java5/bin/javac"
+- compiler="javac1.5"
+ debug="on">
+ <!--
+ <compilerarg line="-Xlint:deprecation -Xlint:unchecked"/>
+index ae4c8d8..2b09fa2 100644
diff --git a/dev-java/jcifs/jcifs-1.3.17-r1.ebuild b/dev-java/jcifs/jcifs-1.3.17-r1.ebuild
new file mode 100644
index 000000000000..cc018a8e0707
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.17-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="http://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="http://jcifs.samba.org/"
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+RDEPEND=">=virtual/jre-1.4
+ java-virtuals/servlet-api:2.4"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+IUSE=""
+
+S=${WORKDIR}/${P/-/_}
+
+java_prepare() {
+ rm -v *.jar || die
+ epatch "${FILESDIR}/${PV}-build.xml.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_EXTRA_ARGS="-DhasServlet=true"
+EANT_GENTOO_CLASSPATH="servlet-api-2.4"
+
+src_install() {
+ java-pkg_newjar ${P}.jar
+
+ dodoc README.txt || die
+ # other stuff besides javadocs
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples examples
+}
diff --git a/dev-java/jcifs/metadata.xml b/dev-java/jcifs/metadata.xml
new file mode 100644
index 000000000000..40818e0723b0
--- /dev/null
+++ b/dev-java/jcifs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+JCIFS is an Open Source client library that implements the CIFS/SMB networking
+protocol in 100% Java. CIFS is the standard file sharing protocol on the
+Microsoft Windows platform (e.g. Map Network Drive ...). This client is used
+extensively in production on large Intranets.
+
+</longdescription>
+</pkgmetadata>