summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jcodings
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jcodings')
-rw-r--r--dev-java/jcodings/Manifest3
-rw-r--r--dev-java/jcodings/files/maven-build.xml176
-rw-r--r--dev-java/jcodings/jcodings-1.0.11.ebuild41
-rw-r--r--dev-java/jcodings/jcodings-1.0.4.ebuild30
-rw-r--r--dev-java/jcodings/jcodings-1.0.5.ebuild37
-rw-r--r--dev-java/jcodings/metadata.xml8
6 files changed, 295 insertions, 0 deletions
diff --git a/dev-java/jcodings/Manifest b/dev-java/jcodings/Manifest
new file mode 100644
index 000000000000..1287b1c5e0be
--- /dev/null
+++ b/dev-java/jcodings/Manifest
@@ -0,0 +1,3 @@
+DIST jcodings-1.0.11.tar.gz 123802 SHA256 b96089463e291ae73215504eb0db876f864e394c767740fbddefac751850542f SHA512 6bff29718ff04fd2f52cff767440d87f3dcb0f4acf71ee7b037241af7ef7533284176f53d08da5b1f37c643b766f4a9113651c994d1893ef302a2056d9ff40f3 WHIRLPOOL 27d5b402a3bc822d126365f4bbc5f3dd87bbcdf69720634333f9b04c4e19ecb00a4af25e676b7b5de81a3f7debaafa8d5b14f6da3aa0583248f96d8b4b3701df
+DIST jcodings-1.0.4-git.tar.gz 90294 SHA256 25332bd415cb0fa997e5f89e37d1c5ebb259629f5be5796c377e0b0624a1767e SHA512 49cdccbb27c9c6859447fa783b22dcd4fa1b9bb6fe9af3e8bddfe3ca4cd62850e4d6c51589481503dba9ea5e27139407834c9163063b74e960bf848ed4f9531e WHIRLPOOL e753dd6a0256de610f65e15eb0988b1790064175ab3027362b8399f11093f8c088399fb9348eb3717ce8bc6803bcb9bcefb2d2f61526fff2b707870ce5cfe7a5
+DIST jcodings-1.0.5-git.tar.gz 90788 SHA256 a5195911c9fc6fb911200b4939acb60ea97c70429da025b02cb03cae8e09f4c4 SHA512 a0122eea18077daefdcf38ec9e6f12b000c558837835fe900f6e0c282fdfcf95dbb10652b4cfeb32e556ae8ebe1aec8c10e4a352cdb565837b2f16335140f8e3 WHIRLPOOL f9b31545169f9539d8c3078a56c721594982b666cffedaf0541243051b1e0237d2169eb414e1105e4b6948ea86f382975d7792d0ca76cb84d9d1165cd78db497
diff --git a/dev-java/jcodings/files/maven-build.xml b/dev-java/jcodings/files/maven-build.xml
new file mode 100644
index 000000000000..c09847a4fa00
--- /dev/null
+++ b/dev-java/jcodings/files/maven-build.xml
@@ -0,0 +1,176 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="jcodings-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jcodings"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="test"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ </target>
+
+</project>
diff --git a/dev-java/jcodings/jcodings-1.0.11.ebuild b/dev-java/jcodings/jcodings-1.0.11.ebuild
new file mode 100644
index 000000000000..eac57c8a5116
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit:0
+ >=dev-java/junit-4.8:4
+ )"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jcodings/jcodings-1.0.4.ebuild b/dev-java/jcodings/jcodings-1.0.4.ebuild
new file mode 100644
index 000000000000..766eaf4fd955
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="source"
+inherit base java-pkg-2 java-ant-2
+
+MY_PN="jruby-${PN}"
+GIT_PV="0-gbaaab90"
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="http://jruby.codehaus.org/"
+#SRC_URI="http://github.com/jruby/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+SRC_URI="mirror://gentoo/${P}-git.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+EANT_BUILD_TARGET="build"
+S="${WORKDIR}/${MY_PN}-${PV}-${GIT_PV}"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jcodings/jcodings-1.0.5.ebuild b/dev-java/jcodings/jcodings-1.0.5.ebuild
new file mode 100644
index 000000000000..37230b79510b
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="http://github.com/jruby/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+src_unpack() {
+ default
+ mv jruby-${PN}-* ${P} || die
+}
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jcodings/metadata.xml b/dev-java/jcodings/metadata.xml
new file mode 100644
index 000000000000..6f87dc795546
--- /dev/null
+++ b/dev-java/jcodings/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">jruby/jcodings</remote-id>
+ </upstream>
+</pkgmetadata>