summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jcommon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jcommon')
-rw-r--r--dev-java/jcommon/Manifest3
-rw-r--r--dev-java/jcommon/jcommon-1.0.16.ebuild47
-rw-r--r--dev-java/jcommon/jcommon-1.0.18.ebuild52
-rw-r--r--dev-java/jcommon/jcommon-1.0.23.ebuild57
-rw-r--r--dev-java/jcommon/metadata.xml8
5 files changed, 167 insertions, 0 deletions
diff --git a/dev-java/jcommon/Manifest b/dev-java/jcommon/Manifest
new file mode 100644
index 000000000000..af8db85e32fb
--- /dev/null
+++ b/dev-java/jcommon/Manifest
@@ -0,0 +1,3 @@
+DIST jcommon-1.0.16.tar.gz 1130148 SHA256 033fd5506d10dcfc7814180b09627e66232fd1ee29b769fc283aa936d7dd607d SHA512 81152e6d19f10eec2abe7704c8bb138448c25f39dcf42a9379e488e9163db041dec18b9407fca4c94e514801af5373c698d3867facc9887f98fb7d8e18086fae WHIRLPOOL e87eaec68455a89ac538ce9fcd3ccbea70efe6f2e5ccb0033c77b823ca5499686b3aaf7b13b29c4187b8b2c9e864cf1ecca2794d5fa37f6dde40da774c94c2c1
+DIST jcommon-1.0.18.tar.gz 1133961 SHA256 a4daf9ed40712bfe9564dcd6eb8392711325aec78fa7c03e57c195f63413e3fd SHA512 83a4dfe7c7f631ee251cd1c133726060d8d380366ba0b39b043327c20e8128fd882b7374448738dcad3e1b6eadc0221242588c15c6feaa3c06101beafe2e79bb WHIRLPOOL cae9c1ff0d3658199378baf2ce58d25710aac17b7bca4d5e31136133868ebb41c6a71fd384a3ba1da2e800d364dd0bf5e70ef768148bbb56d440c78b8fe1e6d4
+DIST jcommon-1.0.23.zip 1373666 SHA256 6351512b94fc2228034a5c43da52d9ef8ecb7781dcecdeba733441de7d7e18f1 SHA512 c358239da8b1ddf53ce94bebb00b6518456aa921dd3aa84fc6a23144d499f14a85ba421cd71f3880e8d10153a6ab816f54c1fa872a4ab694ce3c7b8d69bc2a4b WHIRLPOOL 467d7400a7009c38b86041977dd59f8a309f7a8ecf02226b80112d12aa3d472c9a42a9cc3e5620b64b0333d44f497f85d95a2184603df9eb21ad66a51ca7fa6c
diff --git a/dev-java/jcommon/jcommon-1.0.16.ebuild b/dev-java/jcommon/jcommon-1.0.16.ebuild
new file mode 100644
index 000000000000..138717e1f7f2
--- /dev/null
+++ b/dev-java/jcommon/jcommon-1.0.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 versionator
+
+DESCRIPTION="JCommon is a collection of useful classes used by JFreeChart, JFreeReport and other projects"
+HOMEPAGE="http://www.jfree.org/jcommon"
+MY_P=${PN}-$(replace_version_separator 3 -)
+SRC_URI="mirror://sourceforge/jfreechart/${MY_P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/junit:0 )"
+RDEPEND=">=virtual/jdk-1.4"
+
+S=${WORKDIR}/${MY_P}
+
+java_prepare() {
+ rm -v *.jar lib/*.jar || die
+}
+
+src_compile() {
+ if ! use debug; then
+ antflags="-Dbuild.debug=false -Dbuild.optimize=true"
+ fi
+ eant -f ant/build.xml compile $(use_doc) $antflags
+}
+
+src_test() {
+ java-pkg_jar-from --into lib junit
+ eant -f ant/build.xml compile-junit-tests
+ ejunit -cp "./lib/jcommon-${PV}-junit.jar:$(java-pkg_getjars junit)" \
+ org.jfree.junit.JCommonTestSuite
+}
+
+src_install() {
+ java-pkg_newjar ${P}.jar ${PN}.jar
+ dodoc README.txt || die
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc source/com source/org
+}
diff --git a/dev-java/jcommon/jcommon-1.0.18.ebuild b/dev-java/jcommon/jcommon-1.0.18.ebuild
new file mode 100644
index 000000000000..c209a85a505e
--- /dev/null
+++ b/dev-java/jcommon/jcommon-1.0.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 versionator
+
+MY_P=${PN}-$(replace_version_separator 3 -)
+DESCRIPTION="JCommon is a collection of useful classes used by JFreeChart, JFreeReport and other projects"
+HOMEPAGE="http://www.jfree.org/jcommon"
+SRC_URI="mirror://sourceforge/jfreechart/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ >=virtual/jdk-1.4"
+DEPEND="
+ >=virtual/jdk-1.4
+ test? ( dev-java/junit:4 )"
+
+S=${WORKDIR}/${MY_P}
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.jar' -print -delete || die
+}
+
+src_compile() {
+ if ! use debug; then
+ antflags="-Dbuild.debug=false -Dbuild.optimize=true"
+ fi
+ eant -f ant/build.xml compile $(use_doc) $antflags
+}
+
+src_test() {
+ java-pkg_jar-from --into lib junit-4
+ eant -f ant/build.xml compile-junit-tests
+ ejunit4 -cp "./lib/jcommon-${PV}-junit.jar:$(java-pkg_getjars junit-4)" \
+ org.jfree.junit.JCommonTestSuite
+}
+
+src_install() {
+ java-pkg_newjar ${P}.jar ${PN}.jar
+ dodoc README.txt
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc source/com source/org
+}
diff --git a/dev-java/jcommon/jcommon-1.0.23.ebuild b/dev-java/jcommon/jcommon-1.0.23.ebuild
new file mode 100644
index 000000000000..827b3f1788aa
--- /dev/null
+++ b/dev-java/jcommon/jcommon-1.0.23.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 versionator
+
+MY_P=${PN}-$(replace_version_separator 3 -)
+DESCRIPTION="JCommon is a collection of useful classes used by JFreeChart, JFreeReport and other projects"
+HOMEPAGE="http://www.jfree.org/jcommon"
+SRC_URI="mirror://sourceforge/jfreechart/${MY_P}.zip"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ app-arch/unzip
+ test? ( dev-java/junit:4 )"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"/"${MY_P}"
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.jar' -print -delete || die
+
+ if ! use debug; then
+ antflags="-Dbuild.debug=false -Dbuild.optimize=true"
+ fi
+}
+
+src_compile() {
+ if ! use debug; then
+ antflags="-Dbuild.debug=false -Dbuild.optimize=true"
+ fi
+ eant -f ant/build.xml compile $(use_doc) $antflags
+}
+
+# No tests defined in build.xml. Let's turn them off.
+# src_test() {
+# java-pkg_jar-from --into lib junit-4
+# eant -f ant/build.xml compile-junit-tests
+# ejunit4 -cp "./lib/${P}-junit.jar:$(java-pkg_getjars junit-4)" \
+# org.jfree.junit.JCommonTestSuite
+# }
+
+src_install() {
+ java-pkg_newjar ${P}.jar ${PN}.jar
+ dodoc README.md
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/main/java/com src/main/java/org
+}
diff --git a/dev-java/jcommon/metadata.xml b/dev-java/jcommon/metadata.xml
new file mode 100644
index 000000000000..b23178874827
--- /dev/null
+++ b/dev-java/jcommon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jfreechart</remote-id>
+ </upstream>
+</pkgmetadata>