summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdom/jdom-1.0-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdom/jdom-1.0-r2.ebuild')
-rw-r--r--dev-java/jdom/jdom-1.0-r2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/jdom/jdom-1.0-r2.ebuild b/dev-java/jdom/jdom-1.0-r2.ebuild
new file mode 100644
index 000000000000..b076ce432651
--- /dev/null
+++ b/dev-java/jdom/jdom-1.0-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java API to manipulate XML data"
+SRC_URI="http://www.jdom.org/dist/source/${P}.tar.gz"
+HOMEPAGE="http://www.jdom.org"
+LICENSE="JDOM"
+SLOT="${PV}"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+COMMON_DEP="dev-java/saxpath
+ >=dev-java/xerces-2.7"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm -v build/*.jar lib/*.jar || die
+ rm -rf build/{apidocs,samples} || die
+
+ cd "${S}/lib"
+ java-pkg_jar-from saxpath,xerces-2
+
+ if has_version '=dev-java/jaxen-1.1*'; then
+ elog "jaxen detected - building jaxen support."
+ elog "you can ignore the warnings below"
+ elog "one day there will be better solution"
+ JAVA_PKG_STRICT="" java-pkg_jar-from jaxen-1.1
+ fi
+}
+
+src_compile() {
+ # to prevent a newer jdom from going into cp
+ # (EANT_ANT_TASKS doesn't work with none)
+ ANT_TASKS="none" eant package $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar build/*.jar
+
+ dodoc CHANGES.txt COMMITTERS.txt README.txt TODO.txt || die
+ use doc && java-pkg_dojavadoc build/apidocs
+ use examples && java-pkg_doexamples samples
+ use source && java-pkg_dosrc src/java/org
+}
+
+pkg_postinst() {
+ if ! has_version '=dev-java/jaxen-1.1*'; then
+ elog ""
+ elog "If you want jaxen support for jdom then"
+ elog "please emerge =dev-java/jaxen-1.1* first and"
+ elog "re-emerge jdom. Sorry for the"
+ elog "inconvenience, this is to break out of the"
+ elog "circular dependencies."
+ elog ""
+ fi
+}