summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-11-02 23:24:17 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-11-02 23:40:57 +0000
commit35c081c398a95b522be2ae83ce52616fa6517aed (patch)
treec6b6aa30b83d62a33f3324e0017e6889a9b33939 /dev-java/jflex
parentdev-lang/php: revbump php-5.6.15 to fix a segfault. (diff)
downloadgentoo-35c081c398a95b522be2ae83ce52616fa6517aed.tar.gz
gentoo-35c081c398a95b522be2ae83ce52616fa6517aed.tar.bz2
gentoo-35c081c398a95b522be2ae83ce52616fa6517aed.zip
dev-java/jflex: Rewrite for version bump to 1.6.1
Rewritten using java-pkg-simple to give us more control over this tricky package. javacup has become a PDEPEND, meaning that the bundled version is automatically used on the first build instead of it having a system-jflex USE flag. ~arm keyword added with workarounds for different problems encountered with both IcedTea and Oracle. ~ppc64 keyword temporarily dropped until it gets Java 7, which the newer javacup requires. Please stabilise this at the same time as dev-java/qdox-1.12.1-r1. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-java/jflex')
-rw-r--r--dev-java/jflex/Manifest1
-rw-r--r--dev-java/jflex/files/icedtea-arm.patch18
-rw-r--r--dev-java/jflex/jflex-1.6.1.ebuild121
3 files changed, 140 insertions, 0 deletions
diff --git a/dev-java/jflex/Manifest b/dev-java/jflex/Manifest
index 5a41a586d2dd..b4c0417d84c3 100644
--- a/dev-java/jflex/Manifest
+++ b/dev-java/jflex/Manifest
@@ -1 +1,2 @@
DIST jflex-1.6.0.tar.gz 3035885 SHA256 0774da0ee2d01fc9274179de4243e0d229c01b5cf0fbb78952fb7fdc4672190c SHA512 16ce4a89f75ce5f3da02433ff66d39ed4db567b4cf7469997dd2617b82e52d589bb17ec3a2f36b4d00a62233e48820bc2e043dcc9ae3c01f1eeca323c0166eba WHIRLPOOL 4d9e7e8c3a0da66d860b895699d5b50e29f781f1cf18cab436f545b1fb007297ca9433694ce3808452c5d9340eddc978c2b32019b5a8d5d8c6cb0558543ea18e
+DIST jflex-1.6.1.tar.gz 3027791 SHA256 9879fb4ea7b286af3c3439cf148f5739dfa722edbd978f2f798268b2e016f8c0 SHA512 436840c90d906042205d27e1d3c56dec724bf62cc3d8c8d3445f217af0a50c9ca2bb56ed91f0cd3c37a930f7ca22f4cc50e8c28dbe905f02adf695c8e96fb07b WHIRLPOOL 27e2769b1b1dc720cee71718eca024905fd9e200c53771c2db293471b0190d9a3c9d2245fbbc5ab76a1f22e1496053d35d625a34c09819b1e367f78840152666
diff --git a/dev-java/jflex/files/icedtea-arm.patch b/dev-java/jflex/files/icedtea-arm.patch
new file mode 100644
index 000000000000..acefd9b553e2
--- /dev/null
+++ b/dev-java/jflex/files/icedtea-arm.patch
@@ -0,0 +1,18 @@
+http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2678
+
+diff -Naur jflex-1.6.1.orig/src/main/java/jflex/Emitter.java jflex-1.6.1/src/main/java/jflex/Emitter.java
+--- jflex-1.6.1.orig/src/main/java/jflex/Emitter.java 2015-03-16 17:27:31.000000000 +0000
++++ jflex-1.6.1/src/main/java/jflex/Emitter.java 2015-10-25 23:33:35.784487747 +0000
+@@ -1304,8 +1304,10 @@
+
+ for (int i = 0; i < dfa.numStates; i++) {
+ char j = 0;
+- while ( !isTransition[i] && j < dfa.numInput )
+- isTransition[i] = dfa.table[i][j++] != DFA.NO_TARGET;
++ while ( !isTransition[i] && j < dfa.numInput ) {
++ isTransition[i] = dfa.table[i][j] != DFA.NO_TARGET;
++ j++;
++ }
+ }
+ }
+
diff --git a/dev-java/jflex/jflex-1.6.1.ebuild b/dev-java/jflex/jflex-1.6.1.ebuild
new file mode 100644
index 000000000000..50f314d50813
--- /dev/null
+++ b/dev-java/jflex/jflex-1.6.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JFlex is a lexical analyzer generator for Java"
+HOMEPAGE="http://www.jflex.de/"
+SRC_URI="http://${PN}.de/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples test vim-syntax"
+
+CDEPEND="dev-java/ant-core:0"
+
+RDEPEND=">=virtual/jre-1.6
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )
+ ${CDEPEND}"
+
+PDEPEND=">=dev-java/javacup-0.11b_p20151001:0"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ # See below for details.
+ epatch "${FILESDIR}/icedtea-arm.patch"
+
+ # We need the bundled jflex.jar.
+ rm -rv ${JAVA_SRC_DIR}/java_cup examples/pom.xml || die
+
+ # Remove the bundled java-cup.jar if unneeded.
+ if has_version ${PDEPEND}; then
+ rm -v lib/java-cup-*.jar || die
+ fi
+}
+
+src_configure() {
+ # javacup is a cyclic dependency. Use the package if we have it,
+ # otherwise use the bundled version and install the package later.
+ if has_version ${PDEPEND}; then
+ # Use PORTAGE_QUIET to suppress a QA warning that is spurious
+ # thanks to has_version above. This is Portage-specific but
+ # showing the warning elsewhere isn't the end of the world.
+ JAVACUP=$(PORTAGE_QUIET=1 java-pkg_getjar --build-only javacup javacup.jar)
+ else
+ JAVACUP=$(echo lib/java-cup-*.jar)
+ fi
+
+ JAVA_GENTOO_CLASSPATH_EXTRA="$(java-pkg_getjars --build-only ant-core):${JAVACUP}"
+}
+
+jflex_compile() {
+ java "${@}" jflex.Main -d ${JAVA_SRC_DIR}/${PN} --skel src/main/${PN}/skeleton.nested src/main/${PN}/LexScan.flex || die
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar src/main/resources
+}
+
+src_compile() {
+ java -jar "${JAVACUP}" -destdir ${JAVA_SRC_DIR}/${PN} -package ${PN} -parser LexParse -interface src/main/cup/LexParse.cup || die
+
+ # The IcedTea ARM HotSpot port (as of 2.6.1) hangs when running
+ # jflex. We have patched jflex to fix it but we have to run the
+ # bundled version first. -Xint works around the problem. See
+ # http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2678.
+ use arm && local JFLEX_ARGS="-Xint"
+
+ # First compile (without doc/source) using the bundled jflex.
+ JAVA_PKG_IUSE= jflex_compile -cp "lib/${P}.jar:${JAVACUP}" ${JFLEX_ARGS}
+
+ # Then recompile using the fresh jflex.
+ jflex_compile -cp "${PN}.jar:${JAVACUP}"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${PN} --main ${PN}.Main
+
+ java-pkg_register-dependency javacup javacup-runtime.jar
+ java-pkg_register-ant-task
+
+ use examples && java-pkg_doexamples examples
+ dodoc {changelog,README}.md
+
+ if use doc; then
+ dodoc doc/*.pdf
+ docinto html
+ dodoc doc/*.{css,html,png} doc/COPYRIGHT
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins lib/${PN}.vim
+ fi
+}
+
+src_test() {
+ if use arm && java-pkg_current-vm-matches oracle-jdk-bin-1.8; then
+ # This results in a StackOverflowError as of 1.8.0.65 but works
+ # fine on icedtea:7. Don't know about icedtea:8 yet.
+ rm -v src/test/java/jflex/EmitterTest.java || die
+ fi
+
+ local CP="src/test/java:${PN}.jar:${JAVA_GENTOO_CLASSPATH_EXTRA}:$(java-pkg_getjars junit-4)"
+
+ local TESTS=$(find src/test/java -name "*Test*.java" -printf "%P\n")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -classpath "${CP}" $(find src/test/java -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}