summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jformatstring
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jformatstring')
-rw-r--r--dev-java/jformatstring/Manifest1
-rw-r--r--dev-java/jformatstring/jformatstring-2.0.3.ebuild32
-rw-r--r--dev-java/jformatstring/metadata.xml9
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/jformatstring/Manifest b/dev-java/jformatstring/Manifest
new file mode 100644
index 000000000000..314794ab58a0
--- /dev/null
+++ b/dev-java/jformatstring/Manifest
@@ -0,0 +1 @@
+DIST findbugs-3.0.1-source.zip 9625065 SHA256 bd8ec66550d419ed40283bd78a6268f9af57dcad20b732a9309fd1835abd33ff SHA512 d967769f2356f28b34d92c7451cf3e2ac004e667bfc3b049b5b10b1c19d7be2cfa0db132a77698d042300330f77a2bb5dd8c4baa0d67c37b7e5ae6da9e83a64f WHIRLPOOL 9e407cb5733560d6a548da37becdf1b1b120459a2453d85d4a345a7ff30a3ba1d92179a2586ebfac3c23c6d20f591aed6429b501d6ec791f4b1a390ab77ce387
diff --git a/dev-java/jformatstring/jformatstring-2.0.3.ebuild b/dev-java/jformatstring/jformatstring-2.0.3.ebuild
new file mode 100644
index 000000000000..43592fa3ebba
--- /dev/null
+++ b/dev-java/jformatstring/jformatstring-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FINDBUGS_PV="3.0.1"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Compile time checking for Java format strings"
+SRC_URI="mirror://sourceforge/findbugs/findbugs-${FINDBUGS_PV}-source.zip"
+HOMEPAGE="http://code.google.com/p/j-format-string"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+src_unpack() {
+ unzip -qoj "${DISTDIR}/findbugs-${FINDBUGS_PV}-source.zip" "findbugs-${FINDBUGS_PV}/lib/jFormatString.jar" || die
+ unpack ./jFormatString.jar
+}
+
+java_prepare() {
+ find -name "*.class" -delete || die
+}
diff --git a/dev-java/jformatstring/metadata.xml b/dev-java/jformatstring/metadata.xml
new file mode 100644
index 000000000000..be188d74bc12
--- /dev/null
+++ b/dev-java/jformatstring/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>This code is designed to allow for compile time checking of Java format strings. It can check that the format string is valid, that the proper number of arguments are supplied and that they are of the correct type.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">findbugs</remote-id>
+ </upstream>
+</pkgmetadata>