summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-04-02 01:31:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-04-02 01:38:21 +0200
commit29f23519495f314342c87c486dadc94ff55c7a19 (patch)
tree3143a53b88e55c954be41696fa269bcd788083d2 /dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r2.ebuild
parentdev-perl/Devel-Declare: Bump to version 0.6.19 (diff)
downloadgentoo-29f23519495f314342c87c486dadc94ff55c7a19.tar.gz
gentoo-29f23519495f314342c87c486dadc94ff55c7a19.tar.bz2
gentoo-29f23519495f314342c87c486dadc94ff55c7a19.zip
dev-java/jgoodies-binding: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r2.ebuild')
-rw-r--r--dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r2.ebuild b/dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..c135a628f182
--- /dev/null
+++ b/dev-java/jgoodies-binding/jgoodies-binding-1.1.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_V=${PV//./_}
+
+DESCRIPTION="Bind object properties with UI components"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="mirror://gentoo/binding-${MY_V}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+DOCS=( RELEASE-NOTES.txt README.html )
+
+S="${WORKDIR}/binding-${PV}"
+
+JAVA_SRC_DIR="src/core"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples \
+ src/core \
+ src/tutorial
+ einstalldocs
+}