summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jgroups
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jgroups')
-rw-r--r--dev-java/jgroups/Manifest1
-rw-r--r--dev-java/jgroups/files/2.9.0-ant-1.8-compat.patch20
-rw-r--r--dev-java/jgroups/jgroups-2.9.0.ebuild79
-rw-r--r--dev-java/jgroups/metadata.xml8
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-java/jgroups/Manifest b/dev-java/jgroups/Manifest
new file mode 100644
index 000000000000..67812756fb7d
--- /dev/null
+++ b/dev-java/jgroups/Manifest
@@ -0,0 +1 @@
+DIST JGroups-2.9.0.GA.src.zip 9227273 SHA256 d8094e696b399e109a71289ddb4dc62c0ac52000528bc800056d225b80871a53 SHA512 5482e3a7d895db4d455f92d14c27559eca9370146b397efa4dc17c416a3b833fcfe0753117ca00e1445e49be239f817aad9bb8b626c1b0fb68869f7d1c9ad0df WHIRLPOOL cd46cb18db2b5fdda63f11b76793e58e2b2d8cad1a7e9d391c315b383498bc592ac6ac463dffdae1a33d9e01973fb9030b147b945a72d2ee2a81c692fb2c8f37
diff --git a/dev-java/jgroups/files/2.9.0-ant-1.8-compat.patch b/dev-java/jgroups/files/2.9.0-ant-1.8-compat.patch
new file mode 100644
index 000000000000..46a7820377ec
--- /dev/null
+++ b/dev-java/jgroups/files/2.9.0-ant-1.8-compat.patch
@@ -0,0 +1,20 @@
+--- build.xml.orig 2010-02-28 02:14:36.000000000 +0100
++++ build.xml 2010-02-28 02:15:13.000000000 +0100
+@@ -43,8 +43,6 @@
+ <property name="threadcount" value="false"/>
+ <property name="test.verbose" value="0"/>
+
+- <taskdef resource="testngtasks" classpathref="jg.classpath"/>
+-
+ <!-- properties to determine IP version used -->
+ <condition property="java.net.preferIPv4Stack" value="true" else="false">
+ <isfalse value="${jgroups.useIPv6}"/>
+@@ -63,6 +61,8 @@
+ </fileset>
+ </path>
+
++ <taskdef resource="testngtasks" classpathref="jg.classpath"/>
++
+ <!-- patternsets used to define test sets -->
+ <patternset id="flush.tests">
+ <include name="org/jgroups/tests/FlushTest*"/>
diff --git a/dev-java/jgroups/jgroups-2.9.0.ebuild b/dev-java/jgroups/jgroups-2.9.0.ebuild
new file mode 100644
index 000000000000..810dd77bea48
--- /dev/null
+++ b/dev-java/jgroups/jgroups-2.9.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="JGroups"
+MY_PV="${PV/_p/-sp}"
+MY_P="${MY_PN}-${MY_PV}.GA"
+DESCRIPTION="JGroups is a toolkit for reliable multicast communication"
+SRC_URI="mirror://sourceforge/javagroups/${MY_P}.src.zip"
+HOMEPAGE="http://www.jgroups.org/javagroupsnew/docs/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+RDEPEND=">=virtual/jre-1.5
+ dev-java/bsh:0
+ dev-java/log4j:0
+ java-virtuals/jmx"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}.src
+
+java_prepare() {
+ # bug #305929
+ epatch "${FILESDIR}/2.9.0-ant-1.8-compat.patch"
+
+ cd "${S}/lib" || die
+ rm -v *.jar || die
+
+ java-pkg_jar-from bsh
+ java-pkg_jar-from log4j
+ java-pkg_jar-from --virtual jmx
+
+ # Needed for unit tests
+ #java-pkg_jar-from --build-only junit
+ # One unit tests needs this
+ #java-pkg_jar-from --build-only bcprov
+
+ # Just get rid of these as they are of no use to us as we don't install them
+ # Always tries to compile them.
+ #if ! use test; then
+ rm -vr "${S}"/tests/{junit,other,junit-functional}/org || die
+ rm -v "${S}/src/org/jgroups/util/JUnitXMLReporter.java" || die
+ #fi
+}
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+
+# The jar target generates jgroups-all.jar that has the demos and tests in it
+EANT_BUILD_TARGET="jgroups-core.jar"
+
+src_install() {
+ java-pkg_dojar dist/jgroups-*.jar
+ dodoc CREDITS README || die
+
+ if use doc; then
+ java-pkg_dojavadoc dist/javadoc
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die
+ fi
+ use source && java-pkg_dosrc src/*
+
+}
+
+RESTRICT="test"
+# A lot of these fail. Don't know status in 2.7
+# as need testng in main tree first.
+src_test() {
+ # run the report target for nice html pages
+ ANT_TASKS="ant-junit" eant unittests-xml
+}
diff --git a/dev-java/jgroups/metadata.xml b/dev-java/jgroups/metadata.xml
new file mode 100644
index 000000000000..135a729b92b4
--- /dev/null
+++ b/dev-java/jgroups/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">javagroups</remote-id>
+ </upstream>
+</pkgmetadata>