summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jta/jta-1.0.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jta/jta-1.0.1-r1.ebuild')
-rw-r--r--dev-java/jta/jta-1.0.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jta/jta-1.0.1-r1.ebuild b/dev-java/jta/jta-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..8a3ef8142cd1
--- /dev/null
+++ b/dev-java/jta/jta-1.0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+At="jta-1_0_1B-classes.zip"
+DESCRIPTION="The Java Transaction API"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javaee/tech/jta-138684.html"
+SRC_URI="${At}"
+LICENSE="sun-bcla-jta"
+SLOT=0
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+DEPEND=">=app-arch/unzip-5.50-r1
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Select 'Java Transaction API Specification 1.0.1B Class Files 1.0.1B'"
+ einfo " 3. Download ${At}"
+ einfo " 4. Move file to ${DISTDIR}"
+ einfo " 5. Restart the emerge process"
+ einfo
+}
+
+src_unpack() {
+ unzip -qq "${DISTDIR}"/${At} || die "failed too unpack"
+}
+
+src_compile() {
+ jar cvf jta.jar javax/ || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar jta.jar
+}