summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jusb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jusb')
-rw-r--r--dev-java/jusb/Manifest1
-rw-r--r--dev-java/jusb/files/jusb-0.4.4-makefile.patch15
-rw-r--r--dev-java/jusb/files/jusb-0.4.4-native.patch20
-rw-r--r--dev-java/jusb/jusb-0.4.4-r1.ebuild77
-rw-r--r--dev-java/jusb/metadata.xml8
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-java/jusb/Manifest b/dev-java/jusb/Manifest
new file mode 100644
index 000000000000..8d92219610ee
--- /dev/null
+++ b/dev-java/jusb/Manifest
@@ -0,0 +1 @@
+DIST jusb-0.4.4-src.tgz 92432 SHA256 42782637e3cf190bb4bdf46cd16f827976766ca23d7ef737ac3ed7b11fa0d393 SHA512 a071de83de85fee9f7064cece4cc26ad310ccc1d95cae937cbcc826629f670485f10d36494eb8f31fa7a93727a76573cf82305f3f027ad32e18eda4ac4585995 WHIRLPOOL e59b325a05f2d3567b31e364a0f7cb1c054fa802c70644a521a3f1a2e26eaf86f1b60960e543f667962ff30d4b67b497b126aa1700bed2bfeb38910d9de515c1
diff --git a/dev-java/jusb/files/jusb-0.4.4-makefile.patch b/dev-java/jusb/files/jusb-0.4.4-makefile.patch
new file mode 100644
index 000000000000..70d9b4ca4fcf
--- /dev/null
+++ b/dev-java/jusb/files/jusb-0.4.4-makefile.patch
@@ -0,0 +1,15 @@
+--- Makefile.old 2005-04-17 21:50:21.384681513 +0300
++++ Makefile 2005-04-17 21:51:26.854632179 +0300
+@@ -292,11 +292,7 @@
+ # Native compiles
+ #
+
+-# using nonstandard kernel?
+-KERNEL_INC ?= /home/src/linux/include
+-INCLUDES = -I$(KERNEL_INC)
+-
+-CFLAGS = -g -O $(INCLUDES) $(RPM_OPT_FLAGS)
++CFLAGS += -g -O $(RPM_OPT_FLAGS)
+
+
+ native: $(NATIVE)
diff --git a/dev-java/jusb/files/jusb-0.4.4-native.patch b/dev-java/jusb/files/jusb-0.4.4-native.patch
new file mode 100644
index 000000000000..b583569d86e0
--- /dev/null
+++ b/dev-java/jusb/files/jusb-0.4.4-native.patch
@@ -0,0 +1,20 @@
+diff -u native.old/linux.c native/linux.c
+--- native.old/linux.c 2005-04-17 21:43:13.491277758 +0300
++++ native/linux.c 2005-04-17 21:43:21.986973753 +0300
+@@ -226,11 +226,11 @@
+ } else
+ buffer = NULL;
+
+- ctrl.requesttype = requestType;
+- ctrl.request = request;
+- ctrl.value = value;
+- ctrl.index = index;
+- ctrl.length = len & 0xffff;
++ ctrl.bRequestType = requestType;
++ ctrl.bRequest = request;
++ ctrl.wValue = value;
++ ctrl.wIndex = index;
++ ctrl.wLength = len & 0xffff;
+ ctrl.timeout = TIMEOUT; // USB should t/o after 5 seconds.
+ ctrl.data = buffer + off;
+ if ((retval = ioctl (fd, USBDEVFS_CONTROL, &ctrl)) < 0)
diff --git a/dev-java/jusb/jusb-0.4.4-r1.ebuild b/dev-java/jusb/jusb-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..80aca1eac76e
--- /dev/null
+++ b/dev-java/jusb/jusb-0.4.4-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2 linux-info flag-o-matic multilib
+
+DESCRIPTION="jUSB provides a Free Software Java API for USB"
+HOMEPAGE="http://jusb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.4
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}
+
+CONFIG_CHECK="~USB_DEVICEFS"
+
+ERROR_CONFIG_USB_DEVICEFS="
+You need to turn on the USB device filesystem
+option under USB support in order to use jUSB
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ mkdir src
+ tar -xzf src.tgz -C src
+
+ # The struct usbdevfs_ctrltransfer is different
+ # in latest 2.4 and 2.6 kernels. This patch is
+ # to make jusb compile on 2.6 kernels
+ ! kernel_is 2 4 && epatch ${FILESDIR}/${P}-native.patch
+
+ epatch ${FILESDIR}/${P}-makefile.patch
+
+ sed -i \
+ -e 's#-shared#-shared -Wl,-soname=libjusb.so#' \
+ -e 's#javac#javac $(JAVACFLAGS)#' \
+ "${S}/Makefile" || die "sed failed"
+}
+
+src_compile() {
+ export OSTYPE="linux-gnu"
+
+ # makefile patching isnt worth the trouble, only
+ # one native source file
+ append-flags -fPIC
+
+ # bug #279088
+ emake -j1 || die "Failed to compile"
+ use doc && make javadoc
+}
+
+src_install() {
+ java-pkg_dojar jusb.jar
+ java-pkg_sointo /usr/$(get_libdir)
+ java-pkg_doso libjusb.so
+
+ dodoc README*
+
+ if use doc; then
+ java-pkg_dohtml doc/*.html
+ java-pkg_dohtml -r apidoc/*
+ fi
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jusb/metadata.xml b/dev-java/jusb/metadata.xml
new file mode 100644
index 000000000000..90eb95966c36
--- /dev/null
+++ b/dev-java/jusb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jusb</remote-id>
+ </upstream>
+</pkgmetadata>