summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/libmatthew-java/libmatthew-java-0.7.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/libmatthew-java/libmatthew-java-0.7.2-r1.ebuild')
-rw-r--r--dev-java/libmatthew-java/libmatthew-java-0.7.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/libmatthew-java/libmatthew-java-0.7.2-r1.ebuild b/dev-java/libmatthew-java/libmatthew-java-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..197dd4e2647b
--- /dev/null
+++ b/dev-java/libmatthew-java/libmatthew-java-0.7.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A selection of libraries for Java"
+HOMEPAGE="http://www.matthew.ath.cx/projects/java/"
+SRC_URI="http://www.matthew.ath.cx/projects/java/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-makefile-fixes.patch
+ rm -v "${S}"/cx/ath/matthew/debug/Debug.java || die "rm failed"
+}
+
+src_compile() {
+ CC=$(tc-getCC) LD=$(tc-getCC) INCLUDES="$(java-pkg_get-jni-cflags)" \
+ emake -j1 JARDIR=/usr/share/libmatthew-java/lib JCFLAGS="$(java-pkg_javac-args)" all $(usev doc) || die "emake failed"
+}
+
+src_install() {
+ java-pkg_newjar cgi-0.5.jar cgi.jar
+ java-pkg_newjar debug-disable-1.1.jar debug-disable.jar
+ java-pkg_newjar debug-enable-1.1.jar debug-enable.jar
+ java-pkg_newjar hexdump-0.2.jar hexdump.jar
+ java-pkg_newjar io-0.1.jar io.jar
+ java-pkg_newjar unix-0.5.jar unix.jar
+ java-pkg_doso libcgi-java.so
+ java-pkg_doso libunix-java.so
+ dodoc INSTALL changelog README || die
+ use source && java-pkg_dosrc cx/
+ use doc && java-pkg_dojavadoc doc
+}