summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-10-05 14:55:23 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2016-10-05 14:56:55 +0200
commit9186fd5bb470daebd043b5df59ba292f58bcc354 (patch)
treeee713a2e8ba7edf0a798d84dc2b1f7e06ff3f17c /dev-java/netbeans-websvccommon/netbeans-websvccommon-8.2.ebuild
parentdev-java/netbeans-webcommon: version bump to version 8.2 (diff)
downloadgentoo-9186fd5bb470daebd043b5df59ba292f58bcc354.tar.gz
gentoo-9186fd5bb470daebd043b5df59ba292f58bcc354.tar.bz2
gentoo-9186fd5bb470daebd043b5df59ba292f58bcc354.zip
dev-java/netbeans-websvccommon: version bump to version 8.2
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-java/netbeans-websvccommon/netbeans-websvccommon-8.2.ebuild')
-rw-r--r--dev-java/netbeans-websvccommon/netbeans-websvccommon-8.2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.2.ebuild b/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.2.ebuild
new file mode 100644
index 000000000000..8c858b9f6318
--- /dev/null
+++ b/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans Web Services Common Cluster"
+HOMEPAGE="http://netbeans.org/"
+SLOT="8.2"
+SOURCE_URL="http://download.netbeans.org/netbeans/8.2/final/zip/netbeans-8.2-201609300101-src.zip"
+SRC_URI="${SOURCE_URL}
+ http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.2-build.xml.patch.bz2"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-platform-${PV}
+ ~dev-java/netbeans-ide-${PV}"
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip
+ ${CDEPEND}
+ dev-java/javahelp:0"
+RDEPEND="|| ( virtual/jdk:1.7 virtual/jdk:1.8 )
+ ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.websvccommon -Dext.binaries.downloaded=true -Dpermit.jdk8.builds=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack $(basename ${SOURCE_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-8.2-build.xml.patch.bz2
+}
+
+src_prepare() {
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-8.2-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+
+ einfo "Linking in other clusters..."
+ mkdir "${S}"/nbbuild/netbeans || die
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+ cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.platform.built
+
+ ln -s /usr/share/netbeans-ide-${SLOT} ide || die
+ cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.ide.built
+
+ popd >/dev/null || die
+
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ pushd nbbuild/netbeans/websvccommon >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+ grep -E "/websvccommon$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+ doins -r *
+
+ popd >/dev/null || die
+
+ dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/websvccommon
+}