summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/poi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/poi')
-rw-r--r--dev-java/poi/Manifest2
-rw-r--r--dev-java/poi/files/poi-3.0.2-isADateFormat.patch11
-rw-r--r--dev-java/poi/files/poi-3.0.2-isADateFormatTest.patch45
-rw-r--r--dev-java/poi/metadata.xml5
-rw-r--r--dev-java/poi/poi-3.0.2-r1.ebuild74
-rw-r--r--dev-java/poi/poi-3.2.ebuild62
6 files changed, 199 insertions, 0 deletions
diff --git a/dev-java/poi/Manifest b/dev-java/poi/Manifest
new file mode 100644
index 000000000000..0ade9233f9e7
--- /dev/null
+++ b/dev-java/poi/Manifest
@@ -0,0 +1,2 @@
+DIST poi-src-3.0.2-FINAL-20080204.tar.gz 19034308 SHA256 38a3d599fb75eaaa7c70fec230a9a88c192080b4c07fc9e7c7a31f8b26c8e4eb SHA512 30aa49e7694b6ae904b1362e967b2f0df9990db0c7f51499d60a78285135eef218436419502725083a4cbbc1ae89fc48976ac29cc214b0266b05400c758c6b7a WHIRLPOOL 189dce9e7a399f4a8b0a3cc29e178ac9b190db6d85e528245c54c9789ea895269f493318bfb4f37f51a0c8cdc92a97635c15c9c2ecdde4bfa37a7444667ab47e
+DIST poi-src-3.2-FINAL-20081019.tar.gz 25909967 SHA256 7f39291c4ea12420676680c7e21923e4579b73122710873448dba1673ad03804 SHA512 e6d77f2ae595a7f97f27169cbf67bcde6f21fc05b673e86818b6da6602e7388f9fb6de78837e33067ea2c483c705e48dd08932635c8457f67c79678eb354e1f3 WHIRLPOOL 2d1b64eef8619c913d9b7874f547e072f0acfdc048cae18f8cdbb14a87b3698c597c0163cd0e77fa9043404800576a36b580915a0441b665f26724d564608e84
diff --git a/dev-java/poi/files/poi-3.0.2-isADateFormat.patch b/dev-java/poi/files/poi-3.0.2-isADateFormat.patch
new file mode 100644
index 000000000000..d4743148ef04
--- /dev/null
+++ b/dev-java/poi/files/poi-3.0.2-isADateFormat.patch
@@ -0,0 +1,11 @@
+--- ./src/java/org/apache/poi/hssf/usermodel/HSSFDateUtil.java.orig 2008-02-07 12:02:57.000000000 +0100
++++ ./src/java/org/apache/poi/hssf/usermodel/HSSFDateUtil.java 2008-02-07 12:29:17.000000000 +0100
+@@ -210,7 +210,7 @@
+
+ // Otherwise, check it's only made up of:
+ // y m d - / ,
+- if(fs.matches("^[ymd\\-/, ]+$")) {
++ if(fs.matches("^[yYmMdDhHsS\\-/,. :]+$")) {
+ return true;
+ }
+
diff --git a/dev-java/poi/files/poi-3.0.2-isADateFormatTest.patch b/dev-java/poi/files/poi-3.0.2-isADateFormatTest.patch
new file mode 100644
index 000000000000..b21c1d64316b
--- /dev/null
+++ b/dev-java/poi/files/poi-3.0.2-isADateFormatTest.patch
@@ -0,0 +1,45 @@
+--- poi/trunk/src/testcases/org/apache/poi/hssf/usermodel/TestHSSFDateUtil.java 2007/12/04 17:06:57 601004
++++ poi/trunk/src/testcases/org/apache/poi/hssf/usermodel/TestHSSFDateUtil.java 2008/02/07 12:39:12 619382
+@@ -228,6 +228,7 @@
+ "yyyy-mm-dd", "yyyy/mm/dd", "yy/mm/dd", "yy/mmm/dd",
+ "dd/mm/yy", "dd/mm/yyyy", "dd/mmm/yy",
+ "dd-mm-yy", "dd-mm-yyyy",
++ "DD-MM-YY", "DD-mm-YYYY",
+ "dd\\-mm\\-yy", // Sometimes escaped
+
+ // These crazy ones are valid
+@@ -242,15 +243,33 @@
+ assertTrue( HSSFDateUtil.isADateFormat(formatId, formats[i]) );
+ }
+
++ // Then time based ones too
++ formats = new String[] {
++ "yyyy-mm-dd hh:mm:ss", "yyyy/mm/dd HH:MM:SS",
++ "mm/dd HH:MM", "yy/mmm/dd SS",
++ };
++ for(int i=0; i<formats.length; i++) {
++ assertTrue( HSSFDateUtil.isADateFormat(formatId, formats[i]) );
++ }
++
+ // Then invalid ones
+ formats = new String[] {
+- "yyyy:mm:dd",
++ "yyyy*mm*dd",
+ "0.0", "0.000",
+ "0%", "0.0%",
+ "", null
+ };
+ for(int i=0; i<formats.length; i++) {
+ assertFalse( HSSFDateUtil.isADateFormat(formatId, formats[i]) );
++ }
++
++ // And these are ones we probably shouldn't allow,
++ // but would need a better regexp
++ formats = new String[] {
++ "yyyy:mm:dd",
++ };
++ for(int i=0; i<formats.length; i++) {
++ // assertFalse( HSSFDateUtil.isADateFormat(formatId, formats[i]) );
+ }
+ }
+
diff --git a/dev-java/poi/metadata.xml b/dev-java/poi/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/poi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/poi/poi-3.0.2-r1.ebuild b/dev-java/poi/poi-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..245ce50e7301
--- /dev/null
+++ b/dev-java/poi/poi-3.0.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+JAVA_PKG_IUSE="doc examples source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java API To Access Microsoft Format Files"
+HOMEPAGE="http://poi.apache.org/"
+RELEASE_DATE="20080204"
+SRC_URI="mirror://apache/poi/release/src/${PN}-src-${PV}-FINAL-${RELEASE_DATE}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=dev-java/commons-beanutils-1.7:1.7
+ >=dev-java/commons-lang-2.1:2.1
+ >=dev-java/commons-logging-1.1"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}
+ test? ( dev-java/ant-junit )"
+
+S=${WORKDIR}/${P}-FINAL
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # Patch that adds official fix for detection of custom date/time formats
+ # See bug: http://issues.apache.org/bugzilla/show_bug.cgi?id=44373
+ epatch "${FILESDIR}/${P}-isADateFormat.patch"
+ use test && epatch "${FILESDIR}/${P}-isADateFormatTest.patch"
+
+ find -name "*.jar" | xargs rm -v
+
+ cd "${S}/lib"
+ java-pkg_jar-from commons-logging commons-logging.jar commons-logging-1.1.jar
+ use test && java-pkg_jar-from --build-only junit junit.jar junit-3.8.1.jar
+
+ cd "${S}/src/contrib/lib"
+ java-pkg_jar-from commons-beanutils-1.7 commons-beanutils.jar commons-beanutils-1.7.0.jar
+ java-pkg_jar-from commons-lang-2.1 commons-lang.jar commons-lang-2.1.jar
+
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ # the same target compiles the source and the test so we just mess with
+ # the source directory
+ eant jar $(use_doc javadocs) -Ddisconnected=true \
+ $(use !test && echo -Dmain.src.test=legal -Dscratchpad.src.test=legal)
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test -Ddisconnected=true
+}
+
+src_install() {
+ use doc && java-pkg_dojavadoc build/tmp/site/build/site/*
+ use examples && java-pkg_doexamples src/examples/* src/scratchpad/examples/*
+ use source && java-pkg_dosrc src/contrib/src/org src/java/org src/scratchpad/src/org
+
+ cd build/dist
+ local VERSION=$(get_version_component_range 1-2)
+ java-pkg_newjar poi-scratchpad-${VERSION}* ${PN}-scratchpad.jar
+ java-pkg_newjar poi-contrib-${VERSION}* ${PN}-contrib.jar
+ java-pkg_newjar poi-${VERSION}* ${PN}.jar
+}
diff --git a/dev-java/poi/poi-3.2.ebuild b/dev-java/poi/poi-3.2.ebuild
new file mode 100644
index 000000000000..782886cbc9d4
--- /dev/null
+++ b/dev-java/poi/poi-3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+JAVA_PKG_IUSE="doc examples source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java API To Access Microsoft Format Files"
+HOMEPAGE="http://poi.apache.org/"
+RELEASE_DATE="20081019"
+SRC_URI="mirror://apache/poi/release/src/${PN}-src-${PV}-FINAL-${RELEASE_DATE}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3.2"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=dev-java/commons-logging-1.1"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}
+ test? ( dev-java/ant-junit )"
+
+S=${WORKDIR}/${P}-FINAL
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ find -name "*.jar" | xargs rm -v
+
+ cd "${S}/lib"
+ java-pkg_jar-from commons-logging commons-logging.jar commons-logging-1.1.jar
+ use test && java-pkg_jar-from --build-only junit junit.jar junit-3.8.1.jar
+
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ # the same target compiles the source and the test so we just mess with
+ # the source directory
+ eant jar $(use_doc javadocs) -Ddisconnected=true \
+ $(use !test && echo -Dmain.src.test=legal -Dscratchpad.src.test=legal)
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test -Ddisconnected=true
+}
+
+src_install() {
+ use doc && java-pkg_dojavadoc build/tmp/site/build/site/apidocs
+ use examples && java-pkg_doexamples src/examples/* src/scratchpad/examples/*
+ use source && java-pkg_dosrc src/contrib/src/org src/java/org src/scratchpad/src/org
+
+ cd build/dist || die "Cannot change to dist directory"
+ java-pkg_newjar poi-scratchpad-${PV}* ${PN}-scratchpad.jar
+ java-pkg_newjar poi-contrib-${PV}* ${PN}-contrib.jar
+ java-pkg_newjar poi-${PV}* ${PN}.jar
+}