summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/qdox/qdox-1.6.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/qdox/qdox-1.6.3.ebuild')
-rw-r--r--dev-java/qdox/qdox-1.6.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/qdox/qdox-1.6.3.ebuild b/dev-java/qdox/qdox-1.6.3.ebuild
new file mode 100644
index 000000000000..6c85ec48792a
--- /dev/null
+++ b/dev-java/qdox/qdox-1.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+DESCRIPTION="Parser for extracting class/interface/method definitions"
+HOMEPAGE="https://github.com/codehaus/qdox"
+SRC_URI="http://repository.codehaus.org/com/thoughtworks/${PN}/${PN}/${PV}/${P}-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="1.6"
+KEYWORDS=" amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+CDEPEND="dev-java/ant-core
+ =dev-java/junit-3.8*"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+S=${WORKDIR}
+
+src_compile() {
+ # create jar
+ mkdir -p build/classes
+ ejavac -sourcepath . -d build/classes -classpath $(java-pkg_getjars ant-core,junit) \
+ $(find . -name "*.java") || die "Cannot compile sources"
+ mkdir dist
+ cd build/classes
+ jar -cvf "${S}/dist/${PN}.jar" com || die "Cannot create JAR"
+
+ # generate javadoc
+ if use doc ; then
+ cd "${S}"
+ mkdir javadoc
+ javadoc -d javadoc -sourcepath . -subpackages com \
+ -classpath $(java-pkg_getjars ant-core,junit)
+ fi
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ java-pkg_register-ant-task
+
+ use source && java-pkg_dosrc com
+ use doc && java-pkg_dojavadoc javadoc
+}