summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/reflections
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/reflections')
-rw-r--r--dev-java/reflections/Manifest1
-rw-r--r--dev-java/reflections/metadata.xml6
-rw-r--r--dev-java/reflections/reflections-0.9.9.ebuild35
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/reflections/Manifest b/dev-java/reflections/Manifest
new file mode 100644
index 000000000000..7aeb7096fa20
--- /dev/null
+++ b/dev-java/reflections/Manifest
@@ -0,0 +1 @@
+DIST reflections-0.9.9-sources.jar 56725 SHA256 432803a991d57b551cbd8b2dfc118b6ff2d0263d02a5a02299c017023e81440b SHA512 7a0c65b91444e01364254fa2d2d43b385f7c2cd5254b24fa63d03dfe4ea3d8955094115e2363317ce375e7e602d0e3554d1faf860e4a454a17fe4cac7a24bb13 WHIRLPOOL 5cde67f6a9e6c322c389ae7f37431957b1a7f4311fb1ff008c671fe924e589becc673eacb812a082a1a81ba2dbc6453a42f879f8a65d921a3867d3eeaf6d2ef3
diff --git a/dev-java/reflections/metadata.xml b/dev-java/reflections/metadata.xml
new file mode 100644
index 000000000000..909a9b33f6fd
--- /dev/null
+++ b/dev-java/reflections/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>Reflections scans your classpath, indexes the metadata, allows you to query it on runtime and may save and collect that information for many modules within your project.</longdescription>
+</pkgmetadata>
diff --git a/dev-java/reflections/reflections-0.9.9.ebuild b/dev-java/reflections/reflections-0.9.9.ebuild
new file mode 100644
index 000000000000..2e5e4a6e47d8
--- /dev/null
+++ b/dev-java/reflections/reflections-0.9.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java runtime metadata analysis"
+HOMEPAGE="http://code.google.com/p/reflections/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=org/${PN}/${PN}/${PV}/${P}-sources.jar"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="dev-java/commons-vfs:2
+ dev-java/dom4j:1
+ dev-java/gson:2.2.2
+ dev-java/guava:18
+ dev-java/javassist:3
+ dev-java/jsr305:0
+ dev-java/slf4j-api:0
+ dev-java/tomcat-servlet-api:3.1"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="commons-vfs-2,dom4j-1,gson-2.2.2,guava-18,javassist-3,jsr305,slf4j-api,tomcat-servlet-api-3.1"