summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sat4j-pseudo/sat4j-pseudo-2.3.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sat4j-pseudo/sat4j-pseudo-2.3.1.ebuild')
-rw-r--r--dev-java/sat4j-pseudo/sat4j-pseudo-2.3.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-java/sat4j-pseudo/sat4j-pseudo-2.3.1.ebuild b/dev-java/sat4j-pseudo/sat4j-pseudo-2.3.1.ebuild
new file mode 100644
index 000000000000..7b32cf2f9773
--- /dev/null
+++ b/dev-java/sat4j-pseudo/sat4j-pseudo-2.3.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+MY_PN="org.sat4j.pb"
+MY_PV="20111030"
+BUILD_PV="2.4"
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Pseudo Boolean solvers"
+HOMEPAGE="http://www.sat4j.org/"
+SRC_URI="http://download.forge.objectweb.org/sat4j/sat4j-pb-v${MY_PV}.zip
+ http://download.forge.objectweb.org/sat4j/build-${BUILD_PV}.xml -> ${P}-build.xml"
+LICENSE="LGPL-2.1"
+SLOT="2.3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-java/sat4j-core:2.3"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack sat4j-pb-v${MY_PV}.zip
+}
+
+java_prepare() {
+ mkdir -p {core,pb}/{lib,src} || die
+
+ # Don't complain about missing javadoc stylesheet.
+ touch core/lib/stylesheet.css
+
+ # Grab build.xml. Don't fetch from CVS. Don't build core.
+ sed -e 's/depends="core"//g' \
+ -e 's/depends="prepare,getsource"/depends="prepare"/g' \
+ "${DISTDIR}/${P}-build.xml" > build.xml || die
+
+ # This is the version identifier used for custom builds.
+ echo 'CUSTOM' > core/src/sat4j.version || die
+
+ # Unpack manifest.
+ cd pb || die
+ jar xf "${WORKDIR}/${MY_PN}.jar" META-INF || die
+
+ # Unpack sources.
+ cd src || die
+ jar xf "${WORKDIR}/${MY_PN}-src.jar" || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_TARGET="pseudo"
+EANT_GENTOO_CLASSPATH="sat4j-core-2.3"
+EANT_DOC_TARGET="javadoc -Dmodule=pb -Dlib=pb/lib"
+
+src_install() {
+ java-pkg_dojar dist/CUSTOM/${MY_PN}.jar
+ use doc && java-pkg_dojavadoc api/pb
+ use source && java-pkg_dosrc pb/src/org
+}