summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/servletapi/servletapi-2.4-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/servletapi/servletapi-2.4-r5.ebuild')
-rw-r--r--dev-java/servletapi/servletapi-2.4-r5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/servletapi/servletapi-2.4-r5.ebuild b/dev-java/servletapi/servletapi-2.4-r5.ebuild
new file mode 100644
index 000000000000..551d2722032f
--- /dev/null
+++ b/dev-java/servletapi/servletapi-2.4-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2 java-ant-2
+
+TC_VERSION="5.5.20"
+DESCRIPTION="Servlet API 2.4 from jakarta.apache.org"
+HOMEPAGE="http://jakarta.apache.org/"
+SRC_URI="http://archive.apache.org/dist/tomcat/tomcat-5/v${TC_VERSION}/src/apache-tomcat-${TC_VERSION}-src.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="2.4"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.5
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jdk-1.4"
+
+S="${WORKDIR}/apache-tomcat-${TC_VERSION}-src/servletapi"
+
+src_compile() {
+ local antflags="jar $(use_doc javadoc examples)"
+ eant ${antflags} -f jsr154/build.xml
+ eant ${antflags} -f jsr152/build.xml
+}
+
+src_install() {
+ mv jsr{154,152}/dist/lib/*.jar "${S}"
+
+ if use doc ; then
+ mkdir docs
+ cd "${S}"/jsr154/build
+ mv docs "${S}"/docs/servlet
+ mv examples "${S}"/docs/servlet/examples
+
+ cd "${S}"/jsr152/build
+ mv docs "${S}"/docs/jsp
+ mv examples "${S}"/docs/jsp/examples
+ fi
+
+ cd "${S}"
+ java-pkg_dojar *.jar
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc jsr{152,154}/src/share/javax
+}