summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-06 15:28:04 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-06 15:58:23 +0000
commit9735a73f5b94fdb4b8877bd6838ecca2ece543a7 (patch)
treefc15e371726f492ecc9ac3154c7b89de737c9e1b /dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
parentapp-admin/passwordsafe: Initial version (diff)
downloadgentoo-9735a73f5b94fdb4b8877bd6838ecca2ece543a7.tar.gz
gentoo-9735a73f5b94fdb4b8877bd6838ecca2ece543a7.tar.bz2
gentoo-9735a73f5b94fdb4b8877bd6838ecca2ece543a7.zip
dev-java/spice-jndikit: EAPI 5 and version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/spice-jndikit/spice-jndikit-1.4.ebuild')
-rw-r--r--dev-java/spice-jndikit/spice-jndikit-1.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild b/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
new file mode 100644
index 000000000000..b98bae4ced7a
--- /dev/null
+++ b/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN##*-}"
+
+DESCRIPTION="JNDI Kit is a toolkit designed to help with the construction of JNDI providers"
+HOMEPAGE="https://github.com/realityforge/jndikit"
+SRC_URI="https://github.com/realityforge/${MY_PN}/archive/${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ rm -rf src/test || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ pushd target/classes > /dev/null || die
+ rmic org.realityforge.spice.jndikit.rmi.server.RMINamingProviderImpl \
+ || die "rmic failed"
+ popd > /dev/null || die
+}