summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/spring-aop/spring-aop-3.2.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/spring-aop/spring-aop-3.2.4.ebuild')
-rw-r--r--dev-java/spring-aop/spring-aop-3.2.4.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-java/spring-aop/spring-aop-3.2.4.ebuild b/dev-java/spring-aop/spring-aop-3.2.4.ebuild
new file mode 100644
index 000000000000..f04f360c5a59
--- /dev/null
+++ b/dev-java/spring-aop/spring-aop-3.2.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A comprehensive programming and configuration model for modern Java-based enterprise applications"
+HOMEPAGE="http://www.springsource.org/spring-framework"
+SRC_URI="https://github.com/SpringSource/spring-framework/archive/v${PV}.RELEASE.tar.gz -> spring-framework-${PV}.tar.gz
+ http://dev.gentoo.org/~ercpe/distfiles/dev-java/spring-framework/spring-framework-${PV}-buildscripts.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="3.2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/spring-core:${SLOT}
+ dev-java/spring-beans:${SLOT}
+ dev-java/aopalliance:1
+ dev-java/aspectj:0
+ dev-java/commons-logging:0
+ dev-java/commons-pool:0
+ dev-java/jamon:1"
+
+DEPEND=">=virtual/jdk-1.7
+ test? (
+ dev-java/hamcrest-core:1.3
+ dev-java/hamcrest-library:1.3
+ dev-java/junit:4
+ dev-java/mockito:0
+ dev-java/ant-junit4:0
+ dev-java/xmlunit:1
+ )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CDEPEND}"
+
+S="${WORKDIR}/spring-framework-${PV}.RELEASE/"
+
+EANT_BUILD_XML=${S}/${PN}/build.xml
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="spring-core-${SLOT}
+ spring-beans-${SLOT}
+ aopalliance-1
+ aspectj
+ commons-logging
+ commons-pool
+ jamon-1"
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH}
+ hamcrest-library-1.3
+ hamcrest-core-1.3
+ junit-4
+ mockito
+ xmlunit-1"
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}/dist/${PN}.jar
+
+ use source && java-pkg_dosrc "${S}"/${PN}/src/main/java/org/
+ use doc && java-pkg_dojavadoc "${S}"/${PN}/dist/apidocs/
+}
+
+src_test() {
+ java-pkg-2_src_test
+}