summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-j2ee-deployment-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-j2ee-deployment-bin')
-rw-r--r--dev-java/sun-j2ee-deployment-bin/Manifest2
-rw-r--r--dev-java/sun-j2ee-deployment-bin/metadata.xml5
-rw-r--r--dev-java/sun-j2ee-deployment-bin/sun-j2ee-deployment-bin-1.1-r2.ebuild49
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/sun-j2ee-deployment-bin/Manifest b/dev-java/sun-j2ee-deployment-bin/Manifest
new file mode 100644
index 000000000000..0f8151a756b0
--- /dev/null
+++ b/dev-java/sun-j2ee-deployment-bin/Manifest
@@ -0,0 +1,2 @@
+DIST j2ee_deployment-1_1-fr-class.zip 23165 RMD160 f1c88c7f2a795e835be6d602ed7a17d845ac5f1c SHA1 1f606d5f7f477d60486c2eaef4ede4084d77b877 SHA256 9254f972032ad3f0ba9bd6d51eba5e3f800972d404b432fc790f8546b8fbb88c
+DIST j2ee_deployment-1_1-fr-doc.zip 153966 RMD160 34375b342d1a57a6ff823541da61a37a5af08681 SHA1 94adc32a9a7cedbf5eeb3b76f4b8e13e5380605e SHA256 d6b9c9326d695904669c145ab475d003f736fd3461077cfd58ced07734db18a1
diff --git a/dev-java/sun-j2ee-deployment-bin/metadata.xml b/dev-java/sun-j2ee-deployment-bin/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/sun-j2ee-deployment-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sun-j2ee-deployment-bin/sun-j2ee-deployment-bin-1.1-r2.ebuild b/dev-java/sun-j2ee-deployment-bin/sun-j2ee-deployment-bin-1.1-r2.ebuild
new file mode 100644
index 000000000000..7ee5e69096a9
--- /dev/null
+++ b/dev-java/sun-j2ee-deployment-bin/sun-j2ee-deployment-bin-1.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+MY_PV=${PV/./_}
+
+CLASS_URI="j2ee_deployment-${MY_PV}-fr-class.zip"
+DOC_URI="j2ee_deployment-${MY_PV}-fr-doc.zip"
+
+DESCRIPTION="J2EE Application Deployment Specification"
+HOMEPAGE="http://java.sun.com/j2ee/tools/deployment/"
+SRC_URI="${CLASS_URI}
+ doc? ( ${DOC_URI} )"
+LICENSE="sun-bcla-j2ee-deployment"
+SLOT="1.1"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+DOWNLOAD_URL="https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=J2EE_DEPLOYMENT-1.1-FR-CLASS-G-F@CDS-CDS_Developer"
+DOWNLOAD_URL_DOC="https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=J2EE_DEPLOYMENT-1.1-FR-DOC-G-F@CDS-CDS_Developer"
+
+pkg_nofetch() {
+ einfo "Please download \"J2EE Deployment API Class Files 1.1\" - ${CLASS_URI}"
+ einfo "from ${HOMEPAGE} and move it to ${DISTDIR}"
+ einfo "Direct URL: ${DOWNLOAD_URL}"
+ if use doc; then
+ einfo "Also download \"API Documentation 1.1\" - ${DOC_URI}"
+ einfo "from ${HOMEPAGE} and move it to ${DISTDIR}"
+ einfo "Direct URL: ${DOWNLOAD_URL_DOC}"
+ fi
+}
+
+src_compile() {
+ jar cvf ${PN}.jar javax || die "Failed to create the ${PN}.jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc doc
+}