summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sux4j
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sux4j')
-rw-r--r--dev-java/sux4j/Manifest1
-rw-r--r--dev-java/sux4j/metadata.xml16
-rw-r--r--dev-java/sux4j/sux4j-2.0.ebuild49
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/sux4j/Manifest b/dev-java/sux4j/Manifest
new file mode 100644
index 000000000000..16d8bdb33b6d
--- /dev/null
+++ b/dev-java/sux4j/Manifest
@@ -0,0 +1 @@
+DIST sux4j-2.0-src.tar.gz 103997 SHA256 232845b79e5652ff0fc6e29d06ea0627ba26d9b2f646fae3cb4e6451732f7e35 SHA512 b52e07ea1f4721ad20daf95a02f5c1b79300ce91316696227c04a4af51b9d6d8cecaae0a0abecafb8414157dc1e43659e34402f853466b4ef8040b5dbdd1fc81 WHIRLPOOL d58eb1a9b7d95179679949c4b3df1b109f2c218a469dfd8239dfcfffd37eaacd8848e9ac65f4623bc85938e78294f536d2194dcdde91e05afe9ac2a6472bd4ad
diff --git a/dev-java/sux4j/metadata.xml b/dev-java/sux4j/metadata.xml
new file mode 100644
index 000000000000..18d3cb3a4bb5
--- /dev/null
+++ b/dev-java/sux4j/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ Sux in an umbrella nickname for the results of my fiddling with the implementation of basic succinct data strucures.
+
+The resulting code is rather sparse. The main highlights are:
+
+ * a novel, broadword-based implementation of rank/select queries for up to 264 bits that is highly competitive with known 32-bit implementations on 64-bit architectures (additional space required is 25% for ranking and 12.5%-37.5% for selection);
+ * several Java structures using the Elias–Fano representation of monotone sequences for storing pointers, variable-length bit arrays, etc.
+ * Java code implementing minimal perfect hashing using around 2.65 bits per element (also using some broadword ideas);
+ * a few Java implementation of monotone minimal perfect hashing.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-java/sux4j/sux4j-2.0.ebuild b/dev-java/sux4j/sux4j-2.0.ebuild
new file mode 100644
index 000000000000..c711a01048d4
--- /dev/null
+++ b/dev-java/sux4j/sux4j-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Sux: Implementing Succinct Data Structures"
+HOMEPAGE="http://sux.dsi.unimi.it/"
+SRC_URI="http://sux.dsi.unimi.it/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+COMMON_DEP="dev-java/fastutil:5.0
+ dev-java/commons-io:1
+ dev-java/colt:0
+ dev-java/dsiutils:0
+ dev-java/log4j:0
+ dev-java/commons-collections:0
+ dev-java/commons-configuration:0
+ dev-java/jsap:0
+ dev-java/commons-lang:2.1
+ dev-java/junit:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ java-ant_rewrite-classpath
+}
+
+EANT_GENTOO_CLASSPATH="fastutil-5.0,commons-io-1,colt,dsiutils,log4j,commons-collections,commons-configuration,jsap,commons-lang-2.1,junit"
+
+src_install() {
+ java-pkg_newjar "${P}.jar"
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src
+}