summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/svgsalamander
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/svgsalamander')
-rw-r--r--dev-java/svgsalamander/Manifest1
-rw-r--r--dev-java/svgsalamander/metadata.xml12
-rw-r--r--dev-java/svgsalamander/svgsalamander-0.0-r1.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-java/svgsalamander/Manifest b/dev-java/svgsalamander/Manifest
new file mode 100644
index 000000000000..e29a273982af
--- /dev/null
+++ b/dev-java/svgsalamander/Manifest
@@ -0,0 +1 @@
+DIST svgsalamander-0.0.tar.bz2 2404011 SHA256 38ecb63c6d1e0a39709b69dad8c52f89e3a861bd42ba8a71762a18c03f1276e2 SHA512 70b182d204bac88b33b1c7058c35ae8e83c4ca178829e8c136dee8e1edd9bc6e99dfbd82c8b4c8c556bea110f15dc9e38e7ee266a16cef0ef6792463bb6a8906 WHIRLPOOL 34290892d47f08fbf383e2e5236ae6fece3b0df37d1e0ac71e539e9255396594dc3291fc769eea5b08c8db79849442261599242b39ffb5640b5189cde9dce980
diff --git a/dev-java/svgsalamander/metadata.xml b/dev-java/svgsalamander/metadata.xml
new file mode 100644
index 000000000000..7f188e592ff2
--- /dev/null
+++ b/dev-java/svgsalamander/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ SVG Salamander is an SVG engine for Java that's designed to be small,
+ fast, and allow programmers to use it with a minimum of fuss. It's in
+ particular targeted for making it easy to integrate SVG into Java games
+ and making it much easier for artists to design 2D game content - from
+ rich interactive menus to charts and graphcs to complex animations.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/svgsalamander/svgsalamander-0.0-r1.ebuild b/dev-java/svgsalamander/svgsalamander-0.0-r1.ebuild
new file mode 100644
index 000000000000..445c3a5159de
--- /dev/null
+++ b/dev-java/svgsalamander/svgsalamander-0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+WANT_ANT_TASKS="ant-nodeps ant-trax"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="a SVG engine for Java"
+HOMEPAGE="https://svgsalamander.dev.java.net/"
+# Created from
+# https://svgsalamander.dev.java.net/svn/svgsalamander/tags/release-${PV}
+# with bundled jars removed.
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.5
+ dev-java/ant-core:0"
+
+DEPEND="
+ >=virtual/jdk-1.5
+ dev-java/javacc:0"
+
+java_prepare() {
+ # Delete these so that we don't need junit
+ # They run a dialog any way so not useful for us
+ ecvs_clean
+ rm -vr test/* || die
+
+ cd lib || die
+ java-pkg_jar-from --build-only javacc
+ java-pkg_jar-from ant-core
+}
+
+src_install() {
+ java-pkg_dojar build/jar/*.jar
+ java-pkg_register-ant-task
+
+ use doc && java-pkg_dojavadoc build/javadoc
+ use examples && java-pkg_doexamples examples
+ use source && java-pkg_dosrc src/com
+}