summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-03-03 22:44:37 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-16 20:23:42 +0100
commitf1c6a6236e8dc73ba1905d01cf0d4263cc818d89 (patch)
tree37469bbcfddab03d70a258b617ec5f7502d7a82f /dev-java/tijmp
parentdev-python/mistune: Add ~s390 (diff)
downloadgentoo-f1c6a6236e8dc73ba1905d01cf0d4263cc818d89.tar.gz
gentoo-f1c6a6236e8dc73ba1905d01cf0d4263cc818d89.tar.bz2
gentoo-f1c6a6236e8dc73ba1905d01cf0d4263cc818d89.zip
dev-java/tijmp: EAPI 6 bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-java/tijmp')
-rw-r--r--dev-java/tijmp/files/tijmp-jni.h.patch4
-rw-r--r--dev-java/tijmp/tijmp-0.8-r1.ebuild51
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-java/tijmp/files/tijmp-jni.h.patch b/dev-java/tijmp/files/tijmp-jni.h.patch
index e9f18cc4ee68..02a9b43670b0 100644
--- a/dev-java/tijmp/files/tijmp-jni.h.patch
+++ b/dev-java/tijmp/files/tijmp-jni.h.patch
@@ -1,7 +1,7 @@
# Patch by Vlastimil Babka <caster@gentoo.org>
# Some JDK's such as ibm-jdk-bin don't have jni_md.h, so make the test more robust
---- configure.ac.orig 2009-01-10 00:29:01.000000000 +0100
-+++ configure.ac 2010-04-05 12:17:35.000000000 +0200
+--- a/configure.ac 2009-01-10 00:29:01.000000000 +0100
++++ b/configure.ac 2010-04-05 12:17:35.000000000 +0200
@@ -24,22 +24,16 @@
JAVA_HOME=/usr/local/jdk
fi
diff --git a/dev-java/tijmp/tijmp-0.8-r1.ebuild b/dev-java/tijmp/tijmp-0.8-r1.ebuild
new file mode 100644
index 000000000000..dd16ae342861
--- /dev/null
+++ b/dev-java/tijmp/tijmp-0.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools java-pkg-2
+
+DESCRIPTION="Java Memory Profiler"
+HOMEPAGE="http://www.khelekore.org/jmp/tijmp/"
+SRC_URI="http://www.khelekore.org/jmp/tijmp/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-jni.h.patch"
+ "${FILESDIR}/${P}-respect-javacflags.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" jardir="/usr/share/${PN}/lib/" install
+ java-pkg_regjar "${D}/usr/share/${PN}/lib/${PN}.jar"
+ java-pkg_regso "${D}/usr/$(get_libdir)/lib${PN}.so"
+
+ cat > "${T}/${PN}" <<- "EOF" || die
+#!/usr/bin/env bash
+java -Dtijmp.jar="$(java-config -p tijmp)" -agentlib:tijmp "${@}"
+EOF
+ dobin "${T}/${PN}"
+}
+
+pkg_postinst() {
+ einfo "For your convenience, ${PN} wrapper can be used to run java"
+ einfo "with profiling. Just use it in place of the 'java' command."
+}