summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-01-20 12:35:45 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-01-21 16:38:50 +0000
commit0ff52f6fc836df9b19eb4f182879edab324c18ad (patch)
tree96539ec3f428256cd4f2f17f37c259ccaec8daf3 /dev-java
parentdev-java/java-sdk-docs: version bump to 1.8.0.162 (diff)
downloadgentoo-0ff52f6fc836df9b19eb4f182879edab324c18ad.tar.gz
gentoo-0ff52f6fc836df9b19eb4f182879edab324c18ad.tar.bz2
gentoo-0ff52f6fc836df9b19eb4f182879edab324c18ad.zip
dev-java/java-sdk-docs: Bring Java 8 ebuild in line with Java 9
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild
index d060fa7fcc62..49c3f8aaeb78 100644
--- a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit versionator
@@ -11,11 +11,10 @@ DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-d
|| MY_PV_EXT="u$(get_version_component_range 4)"
MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
-ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
HOMEPAGE="http://download.oracle.com/javase/8/docs/"
-SRC_URI="${ORIG_NAME}"
+SRC_URI="jdk-${MY_PV}-docs-all.zip"
LICENSE="oracle-java-documentation-8"
SLOT="1.8"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
@@ -26,19 +25,20 @@ DEPEND="app-arch/unzip"
S="${WORKDIR}/docs"
pkg_nofetch() {
- einfo "Please download ${ORIG_NAME} from "
+ einfo "Please download ${SRC_URI} from"
einfo "${DOWNLOAD_URL}"
- einfo "(agree to the license) and place it in ${DISTDIR}"
-
+ einfo "by agreeing to the license and place it in ${DISTDIR}"
+ einfo ""
einfo "If you find the file on the download page replaced with a higher"
- einfo "version, please report to the bug 67266 (link below)."
- einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "version, please report it in bug #67266 (link below)."
+ einfo ""
+ einfo "If emerge fails because of a checksum error, it is possible that"
einfo "the upstream release changed without renaming. Try downloading the file"
einfo "again (or a newer revision if available). Otherwise report this to"
einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
}
-src_install(){
- insinto /usr/share/doc/${P}/html
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}/html
doins -r index.html */
}