summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 16:06:45 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-12 17:03:16 +0100
commit2760c354e8b63484471582fb7aa443e83c145ba7 (patch)
tree1f4594b7d2b1fb531386889c688e751e08e6e980 /dev-java
parentdev-python/pypy*: Fix epython.py module first install (diff)
downloadgentoo-2760c354e8b63484471582fb7aa443e83c145ba7.tar.gz
gentoo-2760c354e8b63484471582fb7aa443e83c145ba7.tar.bz2
gentoo-2760c354e8b63484471582fb7aa443e83c145ba7.zip
dev-java/jython: Fix epython.py module first install
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jython/jython-2.5.3-r3.ebuild4
-rw-r--r--dev-java/jython/jython-2.7.0.ebuild9
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-java/jython/jython-2.5.3-r3.ebuild b/dev-java/jython/jython-2.5.3-r3.ebuild
index f35e893b7ead..e455cffd64e2 100644
--- a/dev-java/jython/jython-2.5.3-r3.ebuild
+++ b/dev-java/jython/jython-2.5.3-r3.ebuild
@@ -135,8 +135,8 @@ exec java -cp "$(java-pkg_getjars "${EANT_GENTOO_CLASSPATH}"):${EANT_GENTOO_CLAS
_EOF_
chmod +x "${T}"/jython || die
+ local -x PYTHON="${T}"/jython
python_export jython${SLOT} EPYTHON PYTHON_SITEDIR
- local PYTHON="${T}"/jython
# compile tests (everything else is compiled already)
# we're keeping it quiet since jython reports errors verbosely
@@ -144,6 +144,6 @@ _EOF_
python_optimize "${ED}"/usr/share/jython-${SLOT}/Lib/test &>/dev/null
# for python-exec
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-java/jython/jython-2.7.0.ebuild b/dev-java/jython/jython-2.7.0.ebuild
index f46891f5c2a4..4d60a40192e5 100644
--- a/dev-java/jython/jython-2.7.0.ebuild
+++ b/dev-java/jython/jython-2.7.0.ebuild
@@ -156,8 +156,11 @@ src_install() {
EOF
chmod +x "${T}"/jython || die
- python_export jython${SLOT} EPYTHON PYTHON_SITEDIR
- local PYTHON="${T}"/jython
+ local -x PYTHON="${T}"/jython
+ # we can't get the path from the interpreter since it does some
+ # magic that fails on non-installed copy...
+ local PYTHON_SITEDIR=${EPREFIX}/usr/share/jython-${SLOT}/Lib/site-packages
+ python_export jython${SLOT} EPYTHON
# compile tests (everything else is compiled already)
# we're keeping it quiet since jython reports errors verbosely
@@ -165,7 +168,7 @@ src_install() {
python_optimize "${ED}${instdir}"/Lib/test &>/dev/null
# for python-exec
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
# some of the class files end up with newer timestamps than the files they