summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-20 20:06:53 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-20 20:07:30 +0000
commit569f42e0df69f092417ecdb2495e828c88cad317 (patch)
tree24fb38ee3428d4e9fd3f275237a550f0d7d4921b /dev-java
parentdev-java/cortado: Clean up old. (diff)
downloadgentoo-569f42e0df69f092417ecdb2495e828c88cad317.tar.gz
gentoo-569f42e0df69f092417ecdb2495e828c88cad317.tar.bz2
gentoo-569f42e0df69f092417ecdb2495e828c88cad317.zip
dev-java/jebl: Stable for amd64. Retroactively mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jebl/jebl-2013.02.18.ebuild22
-rw-r--r--dev-java/jebl/jebl-9999.ebuild43
2 files changed, 7 insertions, 58 deletions
diff --git a/dev-java/jebl/jebl-2013.02.18.ebuild b/dev-java/jebl/jebl-2013.02.18.ebuild
index 1cbad0389c43..862383ee30c2 100644
--- a/dev-java/jebl/jebl-2013.02.18.ebuild
+++ b/dev-java/jebl/jebl-2013.02.18.ebuild
@@ -1,34 +1,26 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-
-#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/trunk/jebl"
-#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/tags/${P//./_}"
-
JAVA_PKG_IUSE="doc"
-EANT_BUILD_TARGET="dist"
-EANT_DOC_TARGET="document"
-#inherit subversion java-pkg-2 java-ant-2
inherit java-pkg-2 java-ant-2
DESCRIPTION="Java Evolutionary Biology Library"
HOMEPAGE="http://jebl.sourceforge.net/"
-#SRC_URI=""
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
SLOT="0"
LICENSE="LGPL-2.1"
IUSE=""
-CDEPEND=""
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.5"
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="document"
java_prepare() {
rm -rf "${S}/src/org/virion/jam/maconly" || die
diff --git a/dev-java/jebl/jebl-9999.ebuild b/dev-java/jebl/jebl-9999.ebuild
deleted file mode 100644
index 32115c9f4878..000000000000
--- a/dev-java/jebl/jebl-9999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/trunk/jebl"
-#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/tags/${P//./_}"
-
-JAVA_PKG_IUSE="doc"
-EANT_BUILD_TARGET="dist"
-EANT_DOC_TARGET="document"
-
-inherit subversion java-pkg-2 java-ant-2
-#inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Java Evolutionary Biology Library"
-HOMEPAGE="http://jebl.sourceforge.net/"
-SRC_URI=""
-#SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-KEYWORDS=""
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-CDEPEND=""
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.5"
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.5"
-
-S="${WORKDIR}/${P//./_}"
-
-java_prepare() {
- rm -rf "${S}/src/org/virion/jam/maconly" || die
-}
-
-src_install() {
- java-pkg_dojar dist/jebl.jar || die
- java-pkg_dojar dist/jam.jar || die
- use doc && java-pkg_dojavadoc doc/api
-}