summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-25 11:42:15 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-25 11:42:15 +0200
commit5aa65d3a810bcd3096ff1ad254d071796aaab815 (patch)
treec7db8effeccbce4793cbaf97c066c23f123d0b4f /dev-java
parentdev-java/bsh: update and fixes (diff)
downloadgentoo-5aa65d3a810bcd3096ff1ad254d071796aaab815.tar.gz
gentoo-5aa65d3a810bcd3096ff1ad254d071796aaab815.tar.bz2
gentoo-5aa65d3a810bcd3096ff1ad254d071796aaab815.zip
dev-java/joda-convert: eapi7, doesn't compile with jdk:11, min jdk 1.8
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/joda-convert/joda-convert-1.3.1-r1.ebuild (renamed from dev-java/joda-convert/joda-convert-1.3.1.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-java/joda-convert/joda-convert-1.3.1.ebuild b/dev-java/joda-convert/joda-convert-1.3.1-r1.ebuild
index ed172701ffa4..80b986790cd2 100644
--- a/dev-java/joda-convert/joda-convert-1.3.1.ebuild
+++ b/dev-java/joda-convert/joda-convert-1.3.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
JAVA_PKG_IUSE="doc source test"
inherit java-pkg-2 java-ant-2
@@ -14,18 +14,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ppc64 x86"
-DEPEND=">=virtual/jdk-1.6
+DEPEND="virtual/jdk:1.8
test? (
dev-java/junit:4
dev-java/ant-junit:0
)"
-RDEPEND=">=virtual/jre-1.6"
+RDEPEND=">=virtual/jre-1.8"
JAVA_ANT_REWRITE_CLASSPATH="true"
EANT_TEST_GENTOO_CLASSPATH="junit-4"
EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
-java_prepare() {
+src_prepare() {
+ default
cp "${FILESDIR}"/${P}-build.xml build.xml || die
}