summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-20 01:16:31 +0000
committerSam James <sam@gentoo.org>2020-09-20 02:03:53 +0000
commit8a6f720b8cb577a26cda17c062cc9847db167683 (patch)
tree251248fadba9b1ccdfcd41374290aa100e0fda9b /dev-java
parentdev-java/openjfx: drop old (diff)
downloadgentoo-8a6f720b8cb577a26cda17c062cc9847db167683.tar.gz
gentoo-8a6f720b8cb577a26cda17c062cc9847db167683.tar.bz2
gentoo-8a6f720b8cb577a26cda17c062cc9847db167683.zip
dev-java/jcodings: port to EAPI 7
Closes: https://bugs.gentoo.org/741000 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jcodings/jcodings-1.0.11.ebuild5
-rw-r--r--dev-java/jcodings/jcodings-1.0.5.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-java/jcodings/jcodings-1.0.11.ebuild b/dev-java/jcodings/jcodings-1.0.11.ebuild
index 0800cfad7b1d..e1e86c7657f1 100644
--- a/dev-java/jcodings/jcodings-1.0.11.ebuild
+++ b/dev-java/jcodings/jcodings-1.0.11.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
JAVA_PKG_IUSE="doc source test"
@@ -24,7 +24,8 @@ DEPEND=">=virtual/jdk-1.5
S="${WORKDIR}/${PN}-${PN}-${PV}"
-java_prepare() {
+src_prepare() {
+ default
cp "${FILESDIR}"/maven-build.xml build.xml || die
}
diff --git a/dev-java/jcodings/jcodings-1.0.5.ebuild b/dev-java/jcodings/jcodings-1.0.5.ebuild
index 3d8343932380..8f2c1cf6c1a5 100644
--- a/dev-java/jcodings/jcodings-1.0.5.ebuild
+++ b/dev-java/jcodings/jcodings-1.0.5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
JAVA_PKG_IUSE="doc source"
@@ -14,7 +14,6 @@ SRC_URI="https://github.com/jruby/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
RDEPEND=">=virtual/jre-1.5"
DEPEND=">=virtual/jdk-1.5"
@@ -24,7 +23,8 @@ src_unpack() {
mv jruby-${PN}-* ${P} || die
}
-java_prepare() {
+src_prepare() {
+ default
cp "${FILESDIR}"/maven-build.xml build.xml || die
}