summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-16 20:25:13 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-17 10:55:46 +0000
commitbd7a0640b9909ac554c9255e234cc7baee175feb (patch)
tree325732519e58eaadea133a17e2d52f14ac4ff65f /dev-java
parentapp-crypt/signify: Initial import, ebuild by me. (diff)
downloadgentoo-bd7a0640b9909ac554c9255e234cc7baee175feb.tar.gz
gentoo-bd7a0640b9909ac554c9255e234cc7baee175feb.tar.bz2
gentoo-bd7a0640b9909ac554c9255e234cc7baee175feb.zip
dev-java/jupidator: EAPI 5 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jupidator/Manifest1
-rw-r--r--dev-java/jupidator/jupidator-0.6.0-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jupidator/Manifest b/dev-java/jupidator/Manifest
index cffaea20f235..a393dc742815 100644
--- a/dev-java/jupidator/Manifest
+++ b/dev-java/jupidator/Manifest
@@ -1 +1,2 @@
+DIST jupidator-0.6.0.tar.bz2 253170 SHA256 00213313f794363cc3b4dd8c335cb35cc8582d0d56d72cb941b3edc8f2b94580 SHA512 5e96831ca41b6871eb5f6c883c21eae17474844a74fc5e103b534d6e225d0a16ef98149da1d52728e737607eb7ece586f05aafa0a0ada29c4c28ff3e078a2415 WHIRLPOOL f8625ac738c610c1b3ed60f05a140b0e7367d97189bc27e70666886879c1da74117df360b938718861a4f8a52fdea7e8ed8355b68b33fb459272145481a3f45a
DIST jupidator.0.6.0.tar.bz2 253170 SHA256 00213313f794363cc3b4dd8c335cb35cc8582d0d56d72cb941b3edc8f2b94580 SHA512 5e96831ca41b6871eb5f6c883c21eae17474844a74fc5e103b534d6e225d0a16ef98149da1d52728e737607eb7ece586f05aafa0a0ada29c4c28ff3e078a2415 WHIRLPOOL f8625ac738c610c1b3ed60f05a140b0e7367d97189bc27e70666886879c1da74117df360b938718861a4f8a52fdea7e8ed8355b68b33fb459272145481a3f45a
diff --git a/dev-java/jupidator/jupidator-0.6.0-r1.ebuild b/dev-java/jupidator/jupidator-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..650ed9bc9303
--- /dev/null
+++ b/dev-java/jupidator/jupidator-0.6.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Jupidator is a library/tool in Java for automatic updating of applications"
+HOMEPAGE="http://www.sourceforge.net/projects/jupidator"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ java-pkg_clean
+}