summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-05-13 19:09:11 +0200
committerUlrich Müller <ulm@gentoo.org>2020-05-13 19:11:39 +0200
commit8246f9809943bf639e34c201273994be63680480 (patch)
tree33b63b31ef00964c6e37c227c273b9b93cc6ff84 /dev-lang/c-intercal
parentdev-python/zipp: arm stable wrt bug #720662 (diff)
downloadgentoo-8246f9809943bf639e34c201273994be63680480.tar.gz
gentoo-8246f9809943bf639e34c201273994be63680480.tar.bz2
gentoo-8246f9809943bf639e34c201273994be63680480.zip
dev-lang/c-intercal: Work around test failure with gcc 10.
Bug: https://bugs.gentoo.org/722862 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lang/c-intercal')
-rw-r--r--dev-lang/c-intercal/c-intercal-31.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/c-intercal/c-intercal-31.0.ebuild b/dev-lang/c-intercal/c-intercal-31.0.ebuild
index 5f04f53c129f..bbcc4938fdb2 100644
--- a/dev-lang/c-intercal/c-intercal-31.0.ebuild
+++ b/dev-lang/c-intercal/c-intercal-31.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools elisp-common
+inherit autotools elisp-common flag-o-matic
# C-INTERCAL uses minor-major ordering of version components and
# negative version numbers. We map version components -1, -2, ...
@@ -47,6 +47,11 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ append-flags -fno-toplevel-reorder #722862
+ econf
+}
+
src_compile() {
emake