summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-03-09 11:11:39 +0100
committerUlrich Müller <ulm@gentoo.org>2020-03-09 11:14:43 +0100
commita110a98b4de6f280d770ba3cc92a4612326205a3 (patch)
treee76345803391abbb66678afd649074823aaca7a9 /dev-lang/c-intercal
parentsys-libs/glibc: Remove old (diff)
downloadgentoo-a110a98b4de6f280d770ba3cc92a4612326205a3.tar.gz
gentoo-a110a98b4de6f280d770ba3cc92a4612326205a3.tar.bz2
gentoo-a110a98b4de6f280d770ba3cc92a4612326205a3.zip
dev-lang/c-intercal: Fix build with -fno-common.
Closes: https://bugs.gentoo.org/711902 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lang/c-intercal')
-rw-r--r--dev-lang/c-intercal/c-intercal-31.0.ebuild3
-rw-r--r--dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-lang/c-intercal/c-intercal-31.0.ebuild b/dev-lang/c-intercal/c-intercal-31.0.ebuild
index fa55b57e11b6..5f04f53c129f 100644
--- a/dev-lang/c-intercal/c-intercal-31.0.ebuild
+++ b/dev-lang/c-intercal/c-intercal-31.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,7 @@ SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}"/${P}-version.patch
+ eapply "${FILESDIR}"/${P}-no-common.patch
eapply_user
eautoreconf
}
diff --git a/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
new file mode 100644
index 000000000000..ff409aeb2518
--- /dev/null
+++ b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/711902
+
+--- intercal-0.31-orig/src/perpet.c
++++ intercal-0.31/src/perpet.c
+@@ -85,7 +85,7 @@
+ /* function created by yacc */
+ extern int yyparse(void);
+
+-int yydebug;
++extern int yydebug;
+
+ /* compilation options */
+ bool compile_only; /* just compile into C, don't run the linker */