summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-08-16 11:50:35 +0200
committerUlrich Müller <ulm@gentoo.org>2019-08-16 11:51:10 +0200
commite67879f27d1923d82394822b26149d142d0248f0 (patch)
tree1c67a263d1fd5d1eeda739155c1cd045b4e0db66 /dev-lang/c-intercal
parentmedia-video/plasma-mediacenter: EAPI-7 bump (diff)
downloadgentoo-e67879f27d1923d82394822b26149d142d0248f0.tar.gz
gentoo-e67879f27d1923d82394822b26149d142d0248f0.tar.bz2
gentoo-e67879f27d1923d82394822b26149d142d0248f0.zip
dev-lang/c-intercal: Bump to version 0.31.
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lang/c-intercal')
-rw-r--r--dev-lang/c-intercal/Manifest1
-rw-r--r--dev-lang/c-intercal/c-intercal-31.0.ebuild78
-rw-r--r--dev-lang/c-intercal/files/c-intercal-31.0-version.patch11
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-lang/c-intercal/Manifest b/dev-lang/c-intercal/Manifest
index a61edfb1d683..16c9559dd0f4 100644
--- a/dev-lang/c-intercal/Manifest
+++ b/dev-lang/c-intercal/Manifest
@@ -1 +1,2 @@
DIST intercal-0.30.tar.gz 930759 BLAKE2B c8c9b77c31901da8f7dbd5a76c2d6fa900962c69f4ca56835f750f40370d5161f6311cbe5473cdb7342772c1cc5317e51d91e174cb16985565adacd001fc1f29 SHA512 e82f52082a73e0eb6116026f78fdcc38369f54af828b9ed0d3ca6ed6c40550bfa81db4ca7c4d09015b5db5104a1c06229cfed52e1d202c3a7443f933fbcc0498
+DIST intercal-0.31.tar.gz 940950 BLAKE2B 9a23229b1d7f0524b164a4b66bcab4fdf67a04ba1e411365a46a90d646867fe92d6e328935b406673809535a895becde934fb6cf2e8380943eb8f19473fcedab SHA512 ca5c10be880ce2470d7dd3404fa5a314bd7bcab45cf4908f7108eb1baa50339b876e135251d991527881b564027c63dc38d74a154cbd00d606261013d2b01262
diff --git a/dev-lang/c-intercal/c-intercal-31.0.ebuild b/dev-lang/c-intercal/c-intercal-31.0.ebuild
new file mode 100644
index 000000000000..53c680992b5b
--- /dev/null
+++ b/dev-lang/c-intercal/c-intercal-31.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common
+
+# C-INTERCAL uses minor-major ordering of version components and
+# negative version numbers. We map version components -1, -2, ...
+# to 65535, 65534, ..., and subtract one from the next component.
+# For example, upstream version 0.28 is mapped to Gentoo version 28.0
+# and 0.-2.0.29 is mapped to 28.65535.65534.0.
+#get_intercal_version() {
+# local i=.${1:-${PV}} j k c=0
+# while [[ ${i} ]]; do
+# (( k = ${i##*.} + c ))
+# (( (c = (k >= 32768)) && (k -= 65536) ))
+# i=${i%.*}
+# j=${j}.${k}
+# done
+# echo ${j#.}
+#}
+
+MY_P="${PN#c-}-$(ver_cut 2).$(ver_cut 1)"
+DESCRIPTION="C-INTERCAL - INTERCAL to binary (via C) compiler"
+HOMEPAGE="http://www.catb.org/~esr/intercal/
+ https://gitlab.com/esr/intercal"
+SRC_URI="http://www.catb.org/~esr/intercal/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs examples"
+
+RDEPEND="emacs? ( virtual/emacs )"
+BDEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-version.patch
+ eapply_user
+ eautoreconf
+}
+
+src_compile() {
+ emake
+
+ if use emacs; then
+ elisp-compile etc/intercal.el
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc BUGS NEWS HISTORY README doc/THEORY.txt
+
+ if use emacs; then
+ elisp-install ${PN} etc/intercal.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r pit
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/c-intercal/files/c-intercal-31.0-version.patch b/dev-lang/c-intercal/files/c-intercal-31.0-version.patch
new file mode 100644
index 000000000000..85ce41837f59
--- /dev/null
+++ b/dev-lang/c-intercal/files/c-intercal-31.0-version.patch
@@ -0,0 +1,11 @@
+--- intercal-0.31-orig/configure.ac
++++ intercal-0.31/configure.ac
+@@ -14,7 +14,7 @@
+ subdir-objects no-texinfo.tex -Wall -Wno-override])
+
+ dnl Information about this version of INTERCAL.
+-PACKAGE_VERSION=0.30
++PACKAGE_VERSION=0.31
+ REPOSITORY_URL=`sed -n <control '/XBS-Repository-URL: */s///p'`
+
+ dnl Checks for programs.