summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-08-04 09:39:10 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-04 10:08:23 +0100
commit0ed69fa1a26e3c21027145f0b3a793d5ea0b036c (patch)
tree77e95ed2f7e4a81f8f0159c817fc251167f0e494 /dev-lang/crystal
parentsys-apps/apparmor: remove unnecessary executable bit (diff)
downloadgentoo-0ed69fa1a26e3c21027145f0b3a793d5ea0b036c.tar.gz
gentoo-0ed69fa1a26e3c21027145f0b3a793d5ea0b036c.tar.bz2
gentoo-0ed69fa1a26e3c21027145f0b3a793d5ea0b036c.zip
dev-lang/crystal: bump up to 0.30.0
Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/crystal')
-rw-r--r--dev-lang/crystal/Manifest3
-rw-r--r--dev-lang/crystal/crystal-0.30.0.ebuild123
2 files changed, 126 insertions, 0 deletions
diff --git a/dev-lang/crystal/Manifest b/dev-lang/crystal/Manifest
index 3e1160b53340..561d10327b48 100644
--- a/dev-lang/crystal/Manifest
+++ b/dev-lang/crystal/Manifest
@@ -10,3 +10,6 @@ DIST crystal-0.28.0.tar.gz 2108702 BLAKE2B 75b743c65ae2063ecbcff7514a3fac53ecc0e
DIST crystal-0.29.0-1-linux-i686.tar.gz 31865927 BLAKE2B 1150dd12f4102501bf72a000d6f01e57445966c88de9c9dd2d39e13001067ae97ac3b039db05cb3c02265c3f14fc02b02bc6bd46ad2d4e98da617f668f89176c SHA512 3e3a22b04a5ebd40dfc944c5ba210f230c636634480c836c788db58b4b402b4ce939655a4989ef0ad554fab67d8ecf330d5fd9bd384aad70f78e2dcb16cb2ba6
DIST crystal-0.29.0-1-linux-x86_64.tar.gz 30069384 BLAKE2B cba30b6337654aba0bd081198f30987891a26fe010ecf82413b9be0d965e14a4d7fade0a9fc496985555fd9b24baa5c1bcc3ae6f4a8b6e9fc82fdc1f1b096614 SHA512 81f1652a1a7b9de20644bebc6d4a31c6d2d4681d29662d733d9a5238f5087fcfc1c3f437fb4b81b0a89d7f29492296c4e65706e2aedcae6e34b1902675d80b9b
DIST crystal-0.29.0.tar.gz 2122890 BLAKE2B 17ef4c3c07d326b73bb015a1cd9207c716630877da323e79a59dccb026699e48ec5559039dcad391e775f64324ca9eddeb22f053acb12f5019976f94013d039f SHA512 690183878c1d4f8bea2be419238aae78b40fe06fbfef6b23a31162eab8edec726bd5f87b3e39dbb76d5c3b82dde5d0fcb79ed34474bf62d1ea17c0901ff63337
+DIST crystal-0.30.0-1-linux-i686.tar.gz 31962470 BLAKE2B e913122b8e6fa472b7766c865916a8d6d588fccf1ad85f2c5a7b31334cb5631773e7672eb8fdd1c9bfbefa720b7bef6ea8884e225a29be2a8d8203fa1e2e3455 SHA512 84fd9d66355d069e02805d2f8cc3544ecc90bf6bbbf27b0e5df133264507396cef378f4238e28aff8fc9c8c21cd938d687d11b1924d2530cf5c95b1078eb772b
+DIST crystal-0.30.0-1-linux-x86_64.tar.gz 30157495 BLAKE2B b7e684242f90b7dc0bc93bb2c90e255c65554bfc514616cff645578f1d0956cb9f61262294d3399618bf50c4828e6e83fabd09515d3b7268cbcd96952cba58a4 SHA512 34e5a70ce2305b492bad57cdbcf77603e46052d89cb3b92012cb546ec22af9dbc80c91963b1725e6e1095548e43da766d39fefc2bee827e194d889ccd20c044f
+DIST crystal-0.30.0.tar.gz 2151397 BLAKE2B 8b32d12e6f45d18c5ef23dce0520d7669076295324bcb100e0120779c986ecf9081a23207eaa3696b661dd566c37aada1644d2b5acf2e5ddf447be11b8dabe8a SHA512 9c3da09b8ed57d1fd6942350cefe3be7cf6f1ab32a86329c0eda24138e30f44b822161b8eb3bca057bd8e7b0a47fefbe566af1284f486643080a967c1cb79483
diff --git a/dev-lang/crystal/crystal-0.30.0.ebuild b/dev-lang/crystal/crystal-0.30.0.ebuild
new file mode 100644
index 000000000000..ff834ed3806c
--- /dev/null
+++ b/dev-lang/crystal/crystal-0.30.0.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm multiprocessing toolchain-funcs
+
+BV=0.30.0-1
+BV_AMD64=${BV}-linux-x86_64
+BV_X86=${BV}-linux-i686
+
+DESCRIPTION="The Crystal Programming Language"
+HOMEPAGE="https://crystal-lang.org"
+SRC_URI="https://github.com/crystal-lang/crystal/archive/${PV}.tar.gz -> ${P}.tar.gz
+ amd64? ( https://github.com/crystal-lang/crystal/releases/download/${BV/-*}/crystal-${BV_AMD64}.tar.gz )
+ x86? ( https://github.com/crystal-lang/crystal/releases/download/${BV/-*}/crystal-${BV_X86}.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc debug examples blocking-stdio-hack +xml +yaml"
+
+RESTRICT=test # not stable for day-to-day runs
+
+LLVM_MAX_SLOT=8
+
+# dev-libs/boehm-gc[static-libs] dependency problem, check the issue: https://github.com/manastech/crystal/issues/1382
+DEPEND="
+ sys-devel/llvm:${LLVM_MAX_SLOT}
+ dev-libs/boehm-gc[static-libs,threads]
+ dev-libs/libatomic_ops
+ dev-libs/libevent
+ dev-libs/libpcre
+ sys-libs/libunwind
+ dev-libs/pcl
+ dev-libs/gmp:0
+"
+RDEPEND="${DEPEND}
+ xml? ( dev-libs/libxml2 )
+ yaml? ( dev-libs/libyaml )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.27.1-verbose.patch
+ "${FILESDIR}"/${PN}-0.26.1-gentoo-tests-sandbox.patch
+ "${FILESDIR}"/${PN}-0.26.1-gentoo-tests-network-sandbox-3.patch
+ "${FILESDIR}"/${PN}-0.27.0-extra-spec-flags.patch
+ #"${FILESDIR}"/${PN}-0.27.0-max-age-0-test.patch
+ "${FILESDIR}"/${PN}-0.27.0-gentoo-tests-long-unix.patch
+ "${FILESDIR}"/${PN}-0.27.0-gentoo-tests-long-unix-2.patch
+ "${FILESDIR}"/${PN}-0.27.0-tcp-server-test.patch
+ "${FILESDIR}"/${PN}-0.29.0-no-usr-lib.patch
+)
+
+src_prepare() {
+ default
+
+ use blocking-stdio-hack && eapply "${FILESDIR}"/"${PN}"-0.22.0-blocking-stdio-hack.patch
+}
+
+src_compile() {
+ local bootstrap_path=${WORKDIR}/${PN}-${BV}/bin
+ if [[ ! -d ${bootstrap_path} ]]; then
+ eerror "Binary tarball does not contain expected directory:"
+ die "'${bootstrap_path}' path does not exist."
+ fi
+
+ emake \
+ $(usex debug "" release=1) \
+ progress=true \
+ stats=1 \
+ threads=$(makeopts_jobs) \
+ verbose=1 \
+ \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ \
+ PATH="${bootstrap_path}:${PATH}" \
+ CRYSTAL_PATH=src \
+ CRYSTAL_CONFIG_VERSION=${PV} \
+ CRYSTAL_CONFIG_PATH="lib:${EPREFIX}/usr/$(get_libdir)/crystal"
+ use doc && emake docs
+}
+
+src_test() {
+ # EXTRA_SPEC_FLAGS is useful to debug individual tests
+ # as part of full build:
+ # USE=debug EXTRA_SPEC_FLAGS='-e parse_set_cookie' emerge -1 crystal
+ emake spec \
+ $(usex debug "" release=1) \
+ progress=true \
+ stats=1 \
+ threads=$(makeopts_jobs) \
+ verbose=1 \
+ \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ \
+ CRYSTAL_PATH=src \
+ CRYSTAL_CONFIG_VERSION=${PV} \
+ \
+ "EXTRA_SPEC_FLAGS=${EXTRA_SPEC_FLAGS}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/crystal
+ doins -r src/.
+ dobin .build/crystal
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/completion.zsh _crystal
+
+ use examples && dodoc -r samples
+
+ if use doc ; then
+ docinto api
+ dodoc -r docs/.
+ fi
+
+ newbashcomp etc/completion.bash ${PN}
+}