summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-08-06 18:40:37 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-08 08:21:48 +0100
commit38b2e8b50442fbce04415a9654cf7c66a62a125c (patch)
tree9808decfc89362b556db79c8c6e0374e56afaaf4 /dev-lang/crystal
parentdev-util/debhelper: Old (diff)
downloadgentoo-38b2e8b50442fbce04415a9654cf7c66a62a125c.tar.gz
gentoo-38b2e8b50442fbce04415a9654cf7c66a62a125c.tar.bz2
gentoo-38b2e8b50442fbce04415a9654cf7c66a62a125c.zip
dev-lang/crystal: remove unused patches
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12623 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/crystal')
-rw-r--r--dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch33
-rw-r--r--dev-lang/crystal/files/crystal-0.25.0-verbose.patch9
-rw-r--r--dev-lang/crystal/files/crystal-0.26.0-gentoo-tests-network-sandbox-2.patch23
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch b/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch
deleted file mode 100644
index 12565c1d8390..000000000000
--- a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/spec/std/socket_spec.cr b/spec/std/socket_spec.cr
-index 0caa51a..f21b3b3 100644
---- a/spec/std/socket_spec.cr
-+++ b/spec/std/socket_spec.cr
-@@ -537,13 +537,15 @@ describe TCPSocket do
- end
- end
-
-- it "fails when host doesn't exist" do
-+ # gentoo's FEATURES=network-sandbox blocks DNS
-+ pending "fails when host doesn't exist" do
- expect_raises(Socket::Error, /No address/i) do
- TCPSocket.new("doesnotexist.example.org.", 12345)
- end
- end
-
-- it "fails (rather than segfault on darwin) when host doesn't exist and port is 0" do
-+ # gentoo's FEATURES=network-sandbox blocks DNS
-+ pending "fails (rather than segfault on darwin) when host doesn't exist and port is 0" do
- expect_raises(Socket::Error, /No address/i) do
- TCPSocket.new("doesnotexist.example.org.", 0)
- end
-@@ -634,7 +636,9 @@ describe UDPSocket do
- client.close
- end
-
-- it "broadcasts messages" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # connect: Network is unreachable
-+ pending "broadcasts messages" do
- port = free_udp_socket_port
-
- client = UDPSocket.new(Socket::Family::INET)
diff --git a/dev-lang/crystal/files/crystal-0.25.0-verbose.patch b/dev-lang/crystal/files/crystal-0.25.0-verbose.patch
deleted file mode 100644
index c26e12335e67..000000000000
--- a/dev-lang/crystal/files/crystal-0.25.0-verbose.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 63a9687..995299f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -29,3 +29,3 @@ SOURCES := $(shell find src -name '*.cr')
- SPEC_SOURCES := $(shell find spec -name '*.cr')
--override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
-+override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )$(if $(verbose),--verbose )
- SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
diff --git a/dev-lang/crystal/files/crystal-0.26.0-gentoo-tests-network-sandbox-2.patch b/dev-lang/crystal/files/crystal-0.26.0-gentoo-tests-network-sandbox-2.patch
deleted file mode 100644
index bfe23f9ade8e..000000000000
--- a/dev-lang/crystal/files/crystal-0.26.0-gentoo-tests-network-sandbox-2.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/spec/std/http/server/server_spec.cr
-+++ b/spec/std/http/server/server_spec.cr
-@@ -381,7 +381,9 @@ module HTTP
- end
-
- describe "#bind_ssl" do
-- it "binds SSL server context" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # connect: Connection timed out (Errno)
-+ pending "binds SSL server context" do
- server = Server.new do |context|
- context.response.puts "Test Server (#{context.request.headers["Host"]?})"
- context.response.close
---- a/spec/std/http/web_socket_spec.cr
-+++ b/spec/std/http/web_socket_spec.cr
-@@ -335,4 +335,6 @@ describe HTTP::WebSocket do
- end
-
-- it "negotiates over HTTPS correctly" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # connect: Connection timed out (Errno)
-+ pending "negotiates over HTTPS correctly" do
- address_chan = Channel(Socket::IPAddress).new