summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2018-04-05 20:22:11 +0100
committerIan Whyman <thev00d00@gentoo.org>2018-04-05 20:22:34 +0100
commit28f3f8dc55e7b4296d10d3393c2b22bc035ca056 (patch)
treeabe237e417264c1361954edd03a685170737736d /dev-lang/duktape/duktape-2.2.0.ebuild
parentapp-portage/portage-utils: version bump to 0.70 (diff)
downloadgentoo-28f3f8dc55e7b4296d10d3393c2b22bc035ca056.tar.gz
gentoo-28f3f8dc55e7b4296d10d3393c2b22bc035ca056.tar.bz2
gentoo-28f3f8dc55e7b4296d10d3393c2b22bc035ca056.zip
dev-lang/duktape: Version Bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-lang/duktape/duktape-2.2.0.ebuild')
-rw-r--r--dev-lang/duktape/duktape-2.2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-lang/duktape/duktape-2.2.0.ebuild b/dev-lang/duktape/duktape-2.2.0.ebuild
new file mode 100644
index 000000000000..ca7d7d4b2e18
--- /dev/null
+++ b/dev-lang/duktape/duktape-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Embeddable Javascript engine"
+HOMEPAGE="http://duktape.org"
+SRC_URI="http://duktape.org/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ # Set install path
+ sed -i "s#INSTALL_PREFIX=/usr/local#INSTALL_PREFIX=${D::-1}/usr#" \
+ Makefile.sharedlibrary || die "failed to set install path"
+
+ # Edit pkgconfig
+ sed "s#VERSION#${PV}#" "${FILESDIR}/${PN}.pc" > "${S}/${PN}.pc" || die
+ sed -i "s#LIBDIR#$(get_libdir)#" "${S}/${PN}.pc" || die
+
+ # Set lib folder
+ sed -i "s#(INSTALL_PREFIX)/lib#(INSTALL_PREFIX)/$(get_libdir)#" \
+ Makefile.sharedlibrary || die
+
+ mv Makefile.sharedlibrary Makefile || die "failed to rename makefile"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ dodir /usr/include
+ emake install
+
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins "${S}/${PN}.pc"
+}