summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-08 13:44:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-08 13:44:53 +0100
commit3f014ed5b492cbc954b6df383f7d594d1cf24b13 (patch)
treebd20b1261be37175103205f51b11aa50e54ccbc0 /dev-lang/epic/epic-0.9.3.3-r1.ebuild
parentdev-lang/epic: drop old (diff)
downloadgentoo-3f014ed5b492cbc954b6df383f7d594d1cf24b13.tar.gz
gentoo-3f014ed5b492cbc954b6df383f7d594d1cf24b13.tar.bz2
gentoo-3f014ed5b492cbc954b6df383f7d594d1cf24b13.zip
dev-lang/epic: rename binary from 'epic' to 'epic-epivm', bug #432436
Avoid collision with net-irc/epic4. Reported-by: Diego Elio Pettenò Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/epic/epic-0.9.3.3-r1.ebuild')
-rw-r--r--dev-lang/epic/epic-0.9.3.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/epic/epic-0.9.3.3-r1.ebuild b/dev-lang/epic/epic-0.9.3.3-r1.ebuild
new file mode 100644
index 000000000000..a7b7b2691371
--- /dev/null
+++ b/dev-lang/epic/epic-0.9.3.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Compiler for a simple functional language"
+HOMEPAGE="http://www.dcs.st-and.ac.uk/~eb/epic.php"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cabal:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-libs/boehm-gc-7.0:0=[threads]
+ dev-libs/gmp:0=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.4
+ dev-haskell/happy
+"
+# Bug #438422, upstream at https://github.com/edwinb/EpiVM/issues/5.
+PATCHES=("${FILESDIR}"/${PN}-0.9.3.3-respect-user-cflags.patch)
+
+src_prepare() {
+ default
+
+ # to disambiguare with net-irc/epic4, bug #432436
+ cabal_chdeps \
+ 'Executable epic' 'Executable epic-epivm'
+}