summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-28 22:33:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-28 22:47:14 +0100
commitf6fa6889c4c19340c23b8cd5c34cff167e1953ba (patch)
treebcc0840a813cc81cd98bb7d7d2513fc09016cc65 /dev-lang/ghc/ghc-7.10.2-r1.ebuild
parentapp-misc/beep: Stable for amd64. Fixes bug 144343. (diff)
downloadgentoo-f6fa6889c4c19340c23b8cd5c34cff167e1953ba.tar.gz
gentoo-f6fa6889c4c19340c23b8cd5c34cff167e1953ba.tar.bz2
gentoo-f6fa6889c4c19340c23b8cd5c34cff167e1953ba.zip
dev-lang/ghc: get rid of ncurses dependency, take 2 on bug #557478
Commit 0fdbbebbdc4b18e4078870a6a579834c64177219 removed dependency from ghc binary, but not ghc-pkg binary. This commit fixes that omission and pulls in new binaries. Bug: https://bugs.gentoo.org/557478 Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-lang/ghc/ghc-7.10.2-r1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-7.10.2-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/ghc/ghc-7.10.2-r1.ebuild b/dev-lang/ghc/ghc-7.10.2-r1.ebuild
index d830880c390d..fe3ce0db6d69 100644
--- a/dev-lang/ghc/ghc-7.10.2-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.10.2-r1.ebuild
@@ -27,12 +27,12 @@ arch_binaries=""
# sorted!
#arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~slyfox/ghc-alpha/ghc-bin-${PV}-alpha.tbz2 )"
#arch_binaries="$arch_binaries arm? ( http://code.haskell.org/~slyfox/ghc-arm/ghc-bin-${PV}-arm.tbz2 )"
-arch_binaries="$arch_binaries amd64? ( http://code.haskell.org/~slyfox/ghc-amd64/ghc-bin-${PVR}-amd64.tbz2 )"
+arch_binaries="$arch_binaries amd64? ( http://code.haskell.org/~slyfox/ghc-amd64/ghc-bin-${PVR}-amd64-noncurses.tbz2 )"
#arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
#arch_binaries="$arch_binaries ppc? ( http://code.haskell.org/~slyfox/ghc-ppc/ghc-bin-${PV}-ppc.tbz2 )"
#arch_binaries="$arch_binaries ppc64? ( http://code.haskell.org/~slyfox/ghc-ppc64/ghc-bin-${PV}-ppc64.tbz2 )"
#arch_binaries="$arch_binaries sparc? ( http://code.haskell.org/~slyfox/ghc-sparc/ghc-bin-${PV}-sparc.tbz2 )"
-arch_binaries="$arch_binaries x86? ( http://code.haskell.org/~slyfox/ghc-x86/ghc-bin-${PVR}-x86.tbz2 )"
+arch_binaries="$arch_binaries x86? ( http://code.haskell.org/~slyfox/ghc-x86/ghc-bin-${PVR}-x86-noncurses.tbz2 )"
# various ports:
#arch_binaries="$arch_binaries x86-fbsd? ( http://code.haskell.org/~slyfox/ghc-x86-fbsd/ghc-bin-${PV}-x86-fbsd.tbz2 )"
@@ -529,7 +529,9 @@ src_configure() {
# - embed libffi (default GHC behaviour)
# - disable ncurses support for ghci (via haskeline)
# https://bugs.gentoo.org/557478
+ # - disable ncurses support for ghc-pkg
echo "libraries/haskeline_CONFIGURE_OPTS += --flag=-terminfo" >> mk/build.mk
+ echo "utils/ghc-pkg_HC_OPTS += -DBOOTSTRAPPING" >> mk/build.mk
else
econf_args+=(--with-system-libffi)
econf_args+=(--with-ffi-includes=$(pkg-config libffi --cflags-only-I | sed -e 's@^-I@@'))