summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:51:07 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:50 +0100
commit9e1cc91fd89b0008c8b1531750e07906e7a70f64 (patch)
treec48de18a1c8f23ad114e16b5a0cd6b9cab53acc9 /dev-lang/ghc/ghc-8.6.4.ebuild
parentdev-haskell/gtk: Inline MY_PV in MY_P (diff)
downloadgentoo-9e1cc91fd89b0008c8b1531750e07906e7a70f64.tar.gz
gentoo-9e1cc91fd89b0008c8b1531750e07906e7a70f64.tar.bz2
gentoo-9e1cc91fd89b0008c8b1531750e07906e7a70f64.zip
dev-lang/ghc: Switch/update remaining URLs
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/ghc/ghc-8.6.4.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.6.4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/ghc/ghc-8.6.4.ebuild b/dev-lang/ghc/ghc-8.6.4.ebuild
index 03eca516b7e1..85887f1f738a 100644
--- a/dev-lang/ghc/ghc-8.6.4.ebuild
+++ b/dev-lang/ghc/ghc-8.6.4.ebuild
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
inherit multilib multiprocessing pax-utils toolchain-funcs versionator prefix
inherit check-reqs
DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
# we don't have any binaries yet
arch_binaries=""
@@ -58,8 +58,8 @@ GHC_PV=${PV}
GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
SRC_URI="!binary? (
- http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
- test? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
+ https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
+ test? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
)"
S="${WORKDIR}"/${GHC_P}
@@ -186,7 +186,7 @@ update_SRC_URI() {
set -- $p
pn=$1 pv=$2
- SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+ SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
done
}
@@ -265,7 +265,7 @@ ghc_setup_cflags() {
fi
# prevent from failing to build unregisterised ghc:
- # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+ # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
fi
}