summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-02-07 16:20:26 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-02-07 16:20:26 -0600
commit730b8aa8fcd12cb12791abcbd74eaffa112f9c61 (patch)
tree6182a761810c2106adfadd81ef1e7e4c9e7922fe /dev-lang/go
parentwww-servers/nginx: Remove old (diff)
downloadgentoo-730b8aa8fcd12cb12791abcbd74eaffa112f9c61.tar.gz
gentoo-730b8aa8fcd12cb12791abcbd74eaffa112f9c61.tar.bz2
gentoo-730b8aa8fcd12cb12791abcbd74eaffa112f9c61.zip
dev-lang/go-1.6_rc2 version bump
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/Manifest1
-rw-r--r--dev-lang/go/go-1.6_rc2.ebuild211
2 files changed, 212 insertions, 0 deletions
diff --git a/dev-lang/go/Manifest b/dev-lang/go/Manifest
index 671a66c2838d..545f19cff108 100644
--- a/dev-lang/go/Manifest
+++ b/dev-lang/go/Manifest
@@ -1,3 +1,4 @@
DIST go1.4.2.src.tar.gz 10921896 SHA256 299a6fd8f8adfdce15bc06bde926e7b252ae8e24dd5b16b7d8791ed79e7b5e9b SHA512 cda1a29d4418875dffaf3324004ddae8e1bbb573f7668e6e0c03d8b61284f4db7fca244c181f2859f8ccdd3db6391fb21e0d98a1a9fc15096c15883249d48a9c WHIRLPOOL d06c27f6ff3a6499a6c7cb3c5eccd53eb588896c4d837e1fe9855c22ee3caa5cc48fd68cbeceff105b7c47fafbbf0eb3dc28ee3af7196692c5bf18511c6760ef
DIST go1.5.3.src.tar.gz 12057623 SHA256 754e06dab1c31ab168fc9db9e32596734015ea9e24bc44cae7f237f417ce4efe SHA512 b348832ea7cb095cf793960cf9f4da5e9f6ca8de7b5262bb819de97efea4835643e30a18efd4a82d01ea3854a1905af9e134271716c4b68c9d2a8f6e15f65ff0 WHIRLPOOL aec869ec6af62601f6b83283417eef739141f99be938d419ef4a553028141e05ded7777fdff2a2d1a3e35e4976e4ec96a301b4875c509a370848d0df5dc9e0c8
DIST go1.6rc1.src.tar.gz 12597286 SHA256 2d1a6756f24227dcee955add4af7d194eb4a8c3656b2c4ce778994e21a533a83 SHA512 539ba9603d87bf09d37ab37a7256cb6860357ce976ac000814e733d5ae4f2d1150a4d75412b70dba0fae453aa6fc36c0cc03874d9adce7d23a168551611a47f4 WHIRLPOOL c7f272dfec8a2526bacc1cba165afb5a7c8e6df2540132ce0934795df0c0952752ee7cdee3201a9f13da1f15b13c5b67c0879ef9eedfd60d47be0f9525b37961
+DIST go1.6rc2.src.tar.gz 12602910 SHA256 92914a23cde7e34e1d017175d785e5850fbb28f323a145028e2e26053ef1a598 SHA512 33771377244fd7e7e06e093738fe09381a90f9375e86a807b58e5c2169ffab16eacd832bb28e8e3b759f8ba3283626fe089a3c5bdced4e919218e49eb585e42d WHIRLPOOL b6cc9e0425b74abfa94c0bcbbd0f2e0e82ef6e83ed1d6f8362dfa5beb907db6e424810c9f1b2ec8a00faf65fcaf943eff1e39deec19a14674d5f039795848d3c
diff --git a/dev-lang/go/go-1.6_rc2.ebuild b/dev-lang/go/go-1.6_rc2.ebuild
new file mode 100644
index 000000000000..86910efccb5a
--- /dev/null
+++ b/dev-lang/go/go-1.6_rc2.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+
+MY_PV=${PV/_/}
+
+inherit toolchain-funcs
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/golang/go.git"
+ inherit git-r3
+else
+ SRC_URI="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz"
+ # go-bootstrap-1.4 only supports go on amd64, arm and x86 architectures.
+ # Allowing other bootstrap options would enable arm64 and ppc64 builds.
+ case ${PV} in
+ *9999*|*_rc*) ;;
+ *)
+ KEYWORDS="-* ~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
+ ;;
+ esac
+fi
+
+DESCRIPTION="A concurrent garbage collected and typesafe programming language"
+HOMEPAGE="http://www.golang.org"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND=">=dev-lang/go-bootstrap-1.4.1"
+RDEPEND="!<dev-go/go-tools-0_pre20150902"
+
+# These test data objects have writable/executable stacks.
+QA_EXECSTACK="usr/lib/go/src/debug/elf/testdata/*.obj"
+
+REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
+
+# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
+QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
+
+# The go language uses *.a files which are _NOT_ libraries and should not be
+# stripped. The test data objects should also be left alone and unstripped.
+STRIP_MASK="/usr/lib/go/pkg/*.a
+ /usr/lib/go/src/debug/elf/testdata/*
+ /usr/lib/go/src/debug/dwarf/testdata/*
+ /usr/lib/go/src/runtime/race/*.syso"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}"/go
+fi
+
+go_arch()
+{
+ # By chance most portage arch names match Go
+ local portage_arch=$(tc-arch $@)
+ case "${portage_arch}" in
+ x86) echo 386;;
+ x64-*) echo amd64;;
+ *) echo "${portage_arch}";;
+ esac
+}
+
+go_arm()
+{
+ case "${1:-${CHOST}}" in
+ armv5*) echo 5;;
+ armv6*) echo 6;;
+ armv7*) echo 7;;
+ *)
+ die "unknown GOARM for ${1:-${CHOST}}"
+ ;;
+ esac
+}
+
+go_os()
+{
+ case "${1:-${CHOST}}" in
+ *-linux*) echo linux;;
+ *-darwin*) echo darwin;;
+ *-freebsd*) echo freebsd;;
+ *-netbsd*) echo netbsd;;
+ *-openbsd*) echo openbsd;;
+ *-solaris*) echo solaris;;
+ *-cygwin*|*-interix*|*-winnt*)
+ echo windows
+ ;;
+ *)
+ die "unknown GOOS for ${1:-${CHOST}}"
+ ;;
+ esac
+}
+
+go_tuple()
+{
+ echo "$(go_os $@)_$(go_arch $@)"
+}
+
+go_cross_compile()
+{
+ [[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
+}
+
+pkg_pretend()
+{
+ # make.bash does not understand cross-compiling a cross-compiler
+ if [[ $(go_tuple) != $(go_tuple ${CTARGET}) ]]; then
+ die "CHOST CTARGET pair unsupported: CHOST=${CHOST} CTARGET=${CTARGET}"
+ fi
+}
+
+src_compile()
+{
+ export GOROOT_BOOTSTRAP="${EPREFIX}"/usr/lib/go1.4
+ export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
+ export GOROOT="$(pwd)"
+ export GOBIN="${GOROOT}/bin"
+
+ # Go's build script does not use BUILD/HOST/TARGET consistently. :(
+ export GOHOSTARCH=$(go_arch ${CBUILD})
+ export GOHOSTOS=$(go_os ${CBUILD})
+ export CC=$(tc-getBUILD_CC)
+
+ export GOARCH=$(go_arch)
+ export GOOS=$(go_os)
+ export CC_FOR_TARGET=$(tc-getCC)
+ export CXX_FOR_TARGET=$(tc-getCXX)
+ if [[ ${ARCH} == arm ]]; then
+ export GOARM=$(go_arm)
+ fi
+
+ cd src
+ ./make.bash || die "build failed"
+}
+
+src_test()
+{
+ go_cross_compile && return 0
+
+ cd src
+ PATH="${GOBIN}:${PATH}" \
+ ./run.bash -no-rebuild || die "tests failed"
+}
+
+src_install()
+{
+ local bin_path f x
+
+ dodir /usr/lib/go
+ insinto /usr/lib/go
+
+ # There is a known issue which requires the source tree to be installed [1].
+ # Once this is fixed, we can consider using the doc use flag to control
+ # installing the doc and src directories.
+ # [1] https://golang.org/issue/2775
+ doins -r bin doc lib pkg src
+ fperms -R +x /usr/lib/go/bin /usr/lib/go/pkg/tool
+
+ cp -a misc "${D}"/usr/lib/go/misc
+
+ if go_cross_compile; then
+ bin_path="bin/$(go_tuple)"
+ else
+ bin_path=bin
+ fi
+ for x in ${bin_path}/*; do
+ f=${x##*/}
+ dosym ../lib/go/${bin_path}/${f} /usr/bin/${f}
+ done
+ dodoc AUTHORS CONTRIBUTORS PATENTS README.md
+}
+
+pkg_preinst()
+{
+ has_version '<dev-lang/go-1.4' &&
+ export had_support_files=true ||
+ export had_support_files=false
+}
+
+pkg_postinst()
+{
+ # If the go tool sees a package file timestamped older than a dependancy it
+ # will rebuild that file. So, in order to stop go from rebuilding lots of
+ # packages for every build we need to fix the timestamps. The compiler and
+ # linker are also checked - so we need to fix them too.
+ ebegin "fixing timestamps to avoid unnecessary rebuilds"
+ tref="usr/lib/go/pkg/*/runtime.a"
+ find "${EROOT}"usr/lib/go -type f \
+ -exec touch -r "${EROOT}"${tref} {} \;
+ eend $?
+
+ if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
+ ${REPLACING_VERSIONS} != ${PV} ]]; then
+ elog "Release notes are located at http://golang.org/doc/go${PV}"
+ fi
+
+ if $had_support_files; then
+ ewarn
+ ewarn "All editor support, IDE support, shell completion"
+ ewarn "support, etc has been removed from the go package"
+ ewarn "upstream."
+ ewarn "For more information on which support is available, see"
+ ewarn "the following URL:"
+ ewarn "https://github.com/golang/go/wiki/IDEsAndTextEditorPlugins"
+ fi
+}