summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-10 16:23:15 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:44:59 +0100
commit8032fc02539ad46cdab630488595470d2f565b06 (patch)
tree493d8c019bea7132af12f63cef5a6d8c3037e73a /dev-lang/hy
parentdev-libs/nanomsg: bump to v1.1.5 (diff)
downloadgentoo-8032fc02539ad46cdab630488595470d2f565b06.tar.gz
gentoo-8032fc02539ad46cdab630488595470d2f565b06.tar.bz2
gentoo-8032fc02539ad46cdab630488595470d2f565b06.zip
dev-lang/hy: bump to v0.15.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/hy')
-rw-r--r--dev-lang/hy/Manifest1
-rw-r--r--dev-lang/hy/files/hy-0.15.0-do-not-install-get_version.py.patch22
-rw-r--r--dev-lang/hy/hy-0.15.0.ebuild45
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-lang/hy/Manifest b/dev-lang/hy/Manifest
index e973c928d09d..8a04bde4c5ef 100644
--- a/dev-lang/hy/Manifest
+++ b/dev-lang/hy/Manifest
@@ -6,3 +6,4 @@ DIST hy-0.12.1.tar.gz 379361 BLAKE2B 212a902f287d5b358e9fa4a54ad7bcbf21ed693d6ad
DIST hy-0.13.0.tar.gz 383197 BLAKE2B 5ec7826ebe8b4809c1a49d5dac333fd9e60b5a1a5aee947194df47c5f05bada34f2341e779dcf371c0736721cf93d0d114bb0fe4cd46d124b81c226e39aad533 SHA512 a1138c73584f5dc839d8085aaef24da6450789a0d466cea61ecb3740f865ee2aadc52dde3e5c76d945f16fb88c5fdfa4fd9bbcf35cdcd3fc2337fd1f13548b54
DIST hy-0.13.1.tar.gz 383213 BLAKE2B e002218811cadf8db558284e7124114891c76df334ac3cda7b02c57bcdc37c0e65fb202f07f694d6948159051b88631ec9cb22f22207bf23b39c75125bcfcad3 SHA512 40ec426152ef20ff3d4e23043d9ab178a924a2dca3586fd2dfddf5477612246024222b50e62e6f356649c0d035fd202da89e974acf345db6e5c807883dbb86c5
DIST hy-0.14.0.tar.gz 403692 BLAKE2B 4d20574151c443e002e365bceecc11b2bdcd7aa294073c58cba4ec8a958534c9f1256848ef57e4d5dd3ec345decaa53db43768a78af542ba8a59ff50489486b1 SHA512 a04da48592058b8ad3e7d2a787149622bfcf61c01a341ccc166c2e25e18ed7616b6567b529cf4f6d80a9cecf44aac175577ebf185c77e941a11a258f8563da9e
+DIST hy-0.15.0.tar.gz 411900 BLAKE2B 88a7500ecebacd7995aba1efbabead22ce656b1d6e275c5c726ce9b27746729344adfd35f2dfb4247c6d41101317eecfd98e0379e84f88ffea85bfaef2101797 SHA512 d4a08c7df494c5f9ae9a48e51b642cf8c30850209765fb80304132b57fb1133a839c82945662550d1417f4cae4e15f25da388be180143ed7b28fe8d5129844cc
diff --git a/dev-lang/hy/files/hy-0.15.0-do-not-install-get_version.py.patch b/dev-lang/hy/files/hy-0.15.0-do-not-install-get_version.py.patch
new file mode 100644
index 000000000000..088b382a8913
--- /dev/null
+++ b/dev-lang/hy/files/hy-0.15.0-do-not-install-get_version.py.patch
@@ -0,0 +1,22 @@
+Don't install get_version.py
+
+This reverts commit 7361b37a7580bb5caaf7696b7bff5954042fd52b.
+
+This file is not used at runtime, and the way it was installed violated FHS.
+
+---
+ setup.py | 3 ---
+ 1 file changed, 3 deletions(-)
+
+--- a/setup.py
++++ b/setup.py
+@@ -58,9 +58,6 @@ def run(self):
+ 'hy.core': ['*.hy', '__pycache__/*'],
+ 'hy.extra': ['*.hy', '__pycache__/*'],
+ },
+- data_files=[
+- ('get_version', ['get_version.py'])
+- ],
+ author="Paul Tagliamonte",
+ author_email="tag@pault.ag",
+ long_description=long_description,
diff --git a/dev-lang/hy/hy-0.15.0.ebuild b/dev-lang/hy/hy-0.15.0.ebuild
new file mode 100644
index 000000000000..ad923928b2f8
--- /dev/null
+++ b/dev-lang/hy/hy-0.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python{2_7,3_5,3_6})
+
+inherit distutils-r1 eutils
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/astor-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/clint-0.4[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/funcparserlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.0-do-not-install-get_version.py.patch )
+
+src_prepare() {
+ default
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests -vv || die "Tests failed under ${EPYTHON}"
+}