summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-13 16:25:01 -0400
committerCraig Andrews <candrews@gentoo.org>2019-11-03 08:58:32 -0500
commit963fc6aa8f62f3cef9e536921e24a8603d294deb (patch)
treee5238f511dd75ed0e51a2826044446a6c3beb2f0 /dev-lang/hy
parentdev-lang/hy: Python 3.7 compatibility (diff)
downloadgentoo-963fc6aa8f62f3cef9e536921e24a8603d294deb.tar.gz
gentoo-963fc6aa8f62f3cef9e536921e24a8603d294deb.tar.bz2
gentoo-963fc6aa8f62f3cef9e536921e24a8603d294deb.zip
dev-lang/hy: 0.17.0 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-lang/hy')
-rw-r--r--dev-lang/hy/Manifest1
-rw-r--r--dev-lang/hy/hy-0.17.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-lang/hy/Manifest b/dev-lang/hy/Manifest
index f51f6e06feee..909dd211f2f9 100644
--- a/dev-lang/hy/Manifest
+++ b/dev-lang/hy/Manifest
@@ -8,3 +8,4 @@ DIST hy-0.13.1.tar.gz 383213 BLAKE2B e002218811cadf8db558284e7124114891c76df334a
DIST hy-0.14.0.tar.gz 403692 BLAKE2B 4d20574151c443e002e365bceecc11b2bdcd7aa294073c58cba4ec8a958534c9f1256848ef57e4d5dd3ec345decaa53db43768a78af542ba8a59ff50489486b1 SHA512 a04da48592058b8ad3e7d2a787149622bfcf61c01a341ccc166c2e25e18ed7616b6567b529cf4f6d80a9cecf44aac175577ebf185c77e941a11a258f8563da9e
DIST hy-0.15.0.tar.gz 411900 BLAKE2B 88a7500ecebacd7995aba1efbabead22ce656b1d6e275c5c726ce9b27746729344adfd35f2dfb4247c6d41101317eecfd98e0379e84f88ffea85bfaef2101797 SHA512 d4a08c7df494c5f9ae9a48e51b642cf8c30850209765fb80304132b57fb1133a839c82945662550d1417f4cae4e15f25da388be180143ed7b28fe8d5129844cc
DIST hy-0.16.0.tar.gz 434727 BLAKE2B 05c490049355b496901aea70449e9c30a414bcdd7a5d4a430a672d424eeaa20845d58fd6967433058d4ab6b2969d5744bfdf5dd9cfe976888aeeb35d36a98f91 SHA512 ee9555a58a52bd894904fb0c4892a5c3f0a02b5ab45107ce6ed028840251cc8bd0b1c6264f0f1a345a63352c662861cf3b94049fd58f374dd2ca706ee89c2a4c
+DIST hy-0.17.0.tar.gz 438729 BLAKE2B f699198a3181592dc0a1c12ecb85defce5ee592eb3c949635f37af36f39f452b081b18b46a122d515a7246d448c1710eedd8015a14f18dc074c61f0cfccecf8f SHA512 18601bf47df2120f8833a1ae211c416dc90825f31cd50b259adfe0585089a623d0fea13512b2935b093e14d8595c93bc1610939d5f1d664f6acf7ddf7e341542
diff --git a/dev-lang/hy/hy-0.17.0.ebuild b/dev-lang/hy/hy-0.17.0.ebuild
new file mode 100644
index 000000000000..53cd1fd34d5c
--- /dev/null
+++ b/dev-lang/hy/hy-0.17.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+inherit distutils-r1 eutils
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/astor-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/clint-0.4[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/funcparserlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.0-do-not-install-get_version.py.patch )
+
+src_prepare() {
+ default
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests -vv || die "Tests failed under ${EPYTHON}"
+}