summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-13 09:25:45 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-13 09:25:45 -0600
commit4841f5b9cf06f18b5abd3d9b9edac2aa397a43ff (patch)
treeb1f9066f920eb40b86a213093648e650c5cd6c69 /dev-lang/ispc
parentapp-backup/borgbackup: remove older unstable versions (diff)
downloadgentoo-4841f5b9cf06f18b5abd3d9b9edac2aa397a43ff.tar.gz
gentoo-4841f5b9cf06f18b5abd3d9b9edac2aa397a43ff.tar.bz2
gentoo-4841f5b9cf06f18b5abd3d9b9edac2aa397a43ff.zip
dev-lang/ispc: added live ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
new file mode 100644
index 000000000000..53edbc7adc3a
--- /dev/null
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs python-any-r1
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="https://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_compile() {
+ sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+ dodoc README.rst
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}