summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-06-30 23:37:53 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-06-30 23:49:08 -0500
commit122adfb9f7de4b84dc705470092a35ea6563f4ce (patch)
tree2318f7ff72b398e8344eb2ac176e40a342a2ab16 /dev-lang/julia
parentdev-lang/julia: drop old version 0.6.2 (diff)
downloadgentoo-122adfb9f7de4b84dc705470092a35ea6563f4ce.tar.gz
gentoo-122adfb9f7de4b84dc705470092a35ea6563f4ce.tar.bz2
gentoo-122adfb9f7de4b84dc705470092a35ea6563f4ce.zip
dev-lang/julia: update live ebuild
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/files/julia-9999-fix_build_system.patch29
-rw-r--r--dev-lang/julia/julia-9999.ebuild14
2 files changed, 22 insertions, 21 deletions
diff --git a/dev-lang/julia/files/julia-9999-fix_build_system.patch b/dev-lang/julia/files/julia-9999-fix_build_system.patch
index d7866f46b3e0..336d6e3e590c 100644
--- a/dev-lang/julia/files/julia-9999-fix_build_system.patch
+++ b/dev-lang/julia/files/julia-9999-fix_build_system.patch
@@ -1,8 +1,17 @@
diff --git a/Make.inc b/Make.inc
-index e77681669..bc17c6fd0 100644
+index 8cb2c1014..d3be9de8e 100644
--- a/Make.inc
+++ b/Make.inc
-@@ -399,7 +399,7 @@ ifneq ($(OS), WINNT)
+@@ -178,7 +178,7 @@ USE_GPL_LIBS ?= 1
+ # Directories where said libraries get installed to
+ prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
+ bindir := $(prefix)/bin
+-libdir := $(prefix)/lib
++libdir := $(prefix)/GENTOOLIBDIR
+ libexecdir := $(prefix)/libexec
+ datarootdir := $(prefix)/share
+ docdir := $(datarootdir)/doc/julia
+@@ -410,7 +410,7 @@ ifneq ($(OS), WINNT)
JCXXFLAGS += -pedantic
endif
DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
@@ -11,7 +20,7 @@ index e77681669..bc17c6fd0 100644
endif
ifeq ($(USECLANG),1)
-@@ -410,7 +410,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -421,7 +421,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS := -fasynchronous-unwind-tables
JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -20,7 +29,7 @@ index e77681669..bc17c6fd0 100644
ifeq ($(OS), Darwin)
ifeq ($(USE_LIBCPP), 1)
MACOSX_VERSION_MIN := 10.8
-@@ -439,7 +439,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -450,7 +450,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS :=
JCXXFLAGS := -pipe $(fPIC) -fno-rtti
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -30,10 +39,10 @@ index e77681669..bc17c6fd0 100644
ifeq ($(USECCACHE), 1)
diff --git a/doc/Makefile b/doc/Makefile
-index 743804d8b..e06dde030 100644
+index 89b79880d..c3125fde1 100644
--- a/doc/Makefile
+++ b/doc/Makefile
-@@ -25,7 +25,7 @@ deps: UnicodeData.txt
+@@ -29,7 +29,7 @@ deps: UnicodeData.txt
$(JLCHECKSUM) UnicodeData.txt
clean:
@@ -43,13 +52,14 @@ index 743804d8b..e06dde030 100644
cleanall: clean
diff --git a/src/Makefile b/src/Makefile
-index d3ff98900..9c4d889b4 100644
+index 257152d24..240a4a350 100644
--- a/src/Makefile
+++ b/src/Makefile
-@@ -87,14 +87,7 @@ PUBLIC_HEADERS += $(LIBUV_INC)/uv*
+@@ -85,16 +85,7 @@ UV_HEADERS += uv/*.h
endif
- PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)))
+ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)) $(UV_HEADERS))
+-ifeq ($(JULIACODEGEN),LLVM)
-# In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
-# In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
-ifneq ($(USE_LLVM_SHLIB),1)
@@ -58,6 +68,7 @@ index d3ff98900..9c4d889b4 100644
-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
-FLAGS += -DLLVM_SHLIB
-endif # USE_LLVM_SHLIB == 1
+-endif
+LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
diff --git a/dev-lang/julia/julia-9999.ebuild b/dev-lang/julia/julia-9999.ebuild
index 8e0c10fd4268..ee966c94ec4b 100644
--- a/dev-lang/julia/julia-9999.ebuild
+++ b/dev-lang/julia/julia-9999.ebuild
@@ -51,9 +51,7 @@ PATCHES=(
)
src_prepare() {
- epatch "${PATCHES[@]}"
-
- eapply_user
+ default
# Sledgehammer:
# - respect CFLAGS
@@ -73,12 +71,8 @@ src_prepare() {
liblapack="lib${liblapack#-l}"
sed -i \
- -e "s|\(JULIA_EXECUTABLE = \)\(\$(JULIAHOME)/julia\)|\1 LD_LIBRARY_PATH=\$(BUILD)/$(get_libdir) \2|" \
-e "s|GENTOOCFLAGS|${CFLAGS}|g" \
- -e "s|LIBDIR = lib|LIBDIR = $(get_libdir)|" \
- -e "s|/usr/lib|${EPREFIX}/usr/$(get_libdir)|" \
- -e "s|/usr/include|${EPREFIX}/usr/include|" \
- -e "s|\$(BUILD)/lib|\$(BUILD)/$(get_libdir)|" \
+ -e "s|GENTOOLIBDIR|$(get_libdir)|" \
-e "s|^JULIA_COMMIT = .*|JULIA_COMMIT = v${PV}|" \
-e "s|-lblas|$($(tc-getPKG_CONFIG) --libs blas)|" \
-e "s|= libblas|= ${libblas}|" \
@@ -164,8 +158,4 @@ src_install() {
mv "${ED}"/usr/share/doc/julia/{examples,html} \
"${ED}"/usr/share/doc/${PF} || die
rmdir "${ED}"/usr/share/doc/julia || die
- if [[ $(get_libdir) != lib ]]; then
- mkdir -p "${ED}"/usr/$(get_libdir) || die
- mv "${ED}"/usr/lib/julia "${ED}"/usr/$(get_libdir)/julia || die
- fi
}