summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-17 04:33:48 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-17 04:33:48 +0100
commitf504afcac89ef394347d06ebfc72cc39dd4551e3 (patch)
tree85390768554f5d8ba7073ab343ecf0fd0cc0fc82 /dev-lang/lfe/lfe-1.0.ebuild
parentnet-libs/nodejs: Bump (diff)
downloadgentoo-f504afcac89ef394347d06ebfc72cc39dd4551e3.tar.gz
gentoo-f504afcac89ef394347d06ebfc72cc39dd4551e3.tar.bz2
gentoo-f504afcac89ef394347d06ebfc72cc39dd4551e3.zip
dev-lang/lfe: Bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/lfe/lfe-1.0.ebuild')
-rw-r--r--dev-lang/lfe/lfe-1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/lfe/lfe-1.0.ebuild b/dev-lang/lfe/lfe-1.0.ebuild
new file mode 100644
index 000000000000..623bb9c7e0f2
--- /dev/null
+++ b/dev-lang/lfe/lfe-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Lisp-flavoured Erlang"
+HOMEPAGE="http://lfe.github.io/"
+SRC_URI="https://github.com/rvirding/lfe/archive/v${PV}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ export PATH="${S}/bin:$PATH"
+}
+
+src_compile() {
+ emake compile -j1
+}
+
+src_install() {
+ dobin bin/lfe
+ dobin bin/lfec
+ dobin bin/lfescript
+ dodir /usr/$(get_libdir)/erlang/lib/lfe/ebin/
+ dodir /usr/$(get_libdir)/erlang/lib/lfe/emacs/
+ cp -R "${S}/ebin" "${D}/usr/$(get_libdir)/erlang/lib/lfe/"
+ cp -R "${S}/emacs" "${D}/usr/$(get_libdir)/erlang/lib/lfe/"
+}