summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-11 21:04:30 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-11 21:04:45 +0100
commit026f729e9c13dcc76ea0f43d97342b1164a7271e (patch)
treec82900151e67fe9c4000739db24febb900196511 /dev-lang/maude/maude-2.7.ebuild
parentapp-backup/duply: Version Bump (diff)
downloadgentoo-026f729e9c13dcc76ea0f43d97342b1164a7271e.tar.gz
gentoo-026f729e9c13dcc76ea0f43d97342b1164a7271e.tar.bz2
gentoo-026f729e9c13dcc76ea0f43d97342b1164a7271e.zip
dev-lang/maude: Version bump to 2.7
Gentoo-Bug: 540210 * EAPI=6 * Remove 'autotools-utils.eclass' * Add patch from Debian to fix Bison bug Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-lang/maude/maude-2.7.ebuild')
-rw-r--r--dev-lang/maude/maude-2.7.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-lang/maude/maude-2.7.ebuild b/dev-lang/maude/maude-2.7.ebuild
new file mode 100644
index 000000000000..b48d92e91264
--- /dev/null
+++ b/dev-lang/maude/maude-2.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools versionator
+
+MYP="${PN/m/M}-$(get_version_component_range 1-2)"
+
+DESCRIPTION="High-level specification language for equational and logic programming"
+HOMEPAGE="http://maude.cs.uiuc.edu/"
+SRC_URI="
+ http://maude.cs.illinois.edu/w/images/2/2d/${MYP}.tar.gz
+ https://dev.gentoo.org/~jlec/distfiles/${PN}-2.6-extras.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libsigsegv
+ dev-libs/libtecla
+ sci-libs/buddy"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.0-prll.patch"
+ "${FILESDIR}/${PN}-2.6-search-datadir.patch"
+ "${FILESDIR}/${PN}-2.7-bison-parse-param.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" src/Mixfix/global.hh || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # install data and full maude
+ insinto /usr/share/${PN}
+ doins -r src/Main/*.maude
+ doins "${WORKDIR}"/${PN}-2.6-extras/full-maude.maude
+
+ # install docs and examples
+ use doc && dodoc "${WORKDIR}"/${PN}-2.6-extras/pdfs/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/${PN}-2.6-extras/{manual,primer}-examples
+ fi
+}