summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-06 23:14:40 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-06 23:14:40 +0100
commit1d4a31615b8971b511ad1b3f4ccfc465fd779ab0 (patch)
treeaf20821b6b57ceef9bdf3ef665522db7b83fcaac /dev-lang/mono
parentapp-emulation/grub-xen-host: initial version (diff)
downloadgentoo-1d4a31615b8971b511ad1b3f4ccfc465fd779ab0.tar.gz
gentoo-1d4a31615b8971b511ad1b3f4ccfc465fd779ab0.tar.bz2
gentoo-1d4a31615b8971b511ad1b3f4ccfc465fd779ab0.zip
dev-lang/mono: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-4.2.2.30.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 21fc8006e29b..0556794074e5 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -3,3 +3,4 @@ DIST mono-3.12.1.tar.bz2 73487974 SHA256 5d8cf153af2948c06bc9fbf5088f6834868e4db
DIST mono-4.0.5.1.tar.bz2 96533206 SHA256 c2f42944dded3196c6449f90e79990f1951070a361a0dcc2350fc56e945bc229 SHA512 c0783f7b2e344ca00ea354d2723821636a2594345f7e1fd93bf84e9ba1b5501848d4f49b1538279aac9f6f333d296394322e08a9749fe2208340104aa594cd09 WHIRLPOOL ae9b0758c019003fc9ecdbd051974d547c59c24a4505e71c1fc7db8095bc98cdb486405e2ba1794bfb34ecc6bebeb8b5165a97ba8f596897887eb7f2da806b89
DIST mono-4.2.1.124.tar.bz2 96235544 SHA256 6098476ce5c74685b23e7a96be8fe28a27db4167375fee103a275820054d647c SHA512 56515fdd0ad047756804f2440c302e93f2eaec42dc462680035d0f9c4ea2c3974572b926a468629a49743837beeb8286ff0058392b45a89e9b1fb3ba5299fb8b WHIRLPOOL fe8c6c365d4ab91a1812c7b79a9d0b176eb42aa6515fe486e6de71199be7eaa52dbfd0dad6c31df78bd1a33847dbc45caa4b3928853810e5d354aed16ef6ca13
DIST mono-4.2.2.10.tar.bz2 96232441 SHA256 c772db0be6f108e6832103675c41a3b31439e0203e77a9b321e48ac3bbb9fd25 SHA512 a50082a872e5866d264c1627477accd28539274af1488d0ad92e9fb0d4da56fe35fbe25f57062d7d570a527b9dd6df0d44c586633210c2c7a1fd34ae537bfc62 WHIRLPOOL 40c050a12ccd62ee3ae38ad74d3f0034e341a2d2d4936ff3a73610b265fe946df75741496d655b88e7bc61022d90cae174fc10ada07e93193337dd753b7939f6
+DIST mono-4.2.2.30.tar.bz2 78365827 SHA256 57858cd033be9915d7abdc5158c1faae8fa05757c3b7117cab3d703aa696c56b SHA512 5aa93b362da84970310cc35bf02300718a20d2b508c263f45224d89f7aee84ead90c6fd7230ee2f17a2c02d480e3a8f7d2c9308cec0062a8f4c107f674a7c752 WHIRLPOOL fed4edbc5a724777bfe32edd4493c95904983e295c5c093f36231dfcdd9466daa8a21ed79c2686f8f0c6c5bbef8dafd88e82b3131e69e2d31e99fdc36de5aaf5
diff --git a/dev-lang/mono/mono-4.2.2.30.ebuild b/dev-lang/mono/mono-4.2.2.30.ebuild
new file mode 100644
index 000000000000..1db98fc1c59a
--- /dev/null
+++ b/dev-lang/mono/mono-4.2.2.30.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils linux-info mono-env flag-o-matic pax-utils autotools-utils versionator
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ !dev-lang/mono-basic
+"
+
+MAKEOPTS="${MAKEOPTS} -j1" #nowarn
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+pkg_pretend() {
+ # If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
+ # See http://bugs.gentoo.org/261869 for more info."
+ CONFIG_CHECK="SYSVIPC"
+ use kernel_linux && check_extra_config
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ # Fix VB targets
+ # http://osdir.com/ml/general/2015-05/msg20808.html
+ epatch "${FILESDIR}/add_missing_vb_portable_targets.patch"
+
+ # Fix build when sgen disabled
+ # https://bugzilla.xamarin.com/show_bug.cgi?id=32015
+ epatch "${FILESDIR}/${PN}-4.0.2.5-fix-mono-dis-makefile-am-when-without-sgen.patch"
+
+ # Fix atomic_add_i4 support for 32-bit ppc
+ # https://github.com/mono/mono/compare/f967c79926900343f399c75624deedaba460e544^...8f379f0c8f98493180b508b9e68b9aa76c0c5bdf
+ epatch "${FILESDIR}/${PN}-4.0.2.5-fix-ppc-atomic-add-i4.patch"
+
+ epatch "${FILESDIR}/systemweb3.patch"
+ epatch "${FILESDIR}/fix-for-GitExtensions-issue-2710-another-resolution.patch"
+ epatch "${FILESDIR}/fix-for-bug36724.patch"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}