summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-22 01:31:38 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-22 03:04:59 +1200
commit22adcbd7407e458623ec65eb4a2f051397aabfd0 (patch)
tree7b3fc6f85cb4deedf85b4b4db9249d23ab664b24 /dev-lang/perl
parentdev-lang/perl: Ensure PATCH_BASE is common between -9999 and not (diff)
downloadgentoo-22adcbd7407e458623ec65eb4a2f051397aabfd0.tar.gz
gentoo-22adcbd7407e458623ec65eb4a2f051397aabfd0.tar.bz2
gentoo-22adcbd7407e458623ec65eb4a2f051397aabfd0.zip
dev-lang/perl: Fix subslot/MY_PV computation from DIST_VERSION
This is a result of the oversight that PV contains _rc and DIST_VERSION contains -RC, and this leads to the latter leaking into libpaths and subslots, where it shouldn't. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-lang/perl')
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index 908abf6dd825..5162f5484709 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -15,14 +15,15 @@ DIST_AUTHOR=XSAWYERX
# Devel point-releases are not ABI-intercompatible, but stable point releases are
# BIN_OLDVERSEN is contains only C-ABI-intercompatible versions
PERL_BIN_OLDVERSEN=""
-PERL_OLDVERSEN="5.25.12 5.25.11 5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
+# Don't add more -RC values, its historical bungling
+PERL_OLDVERSEN="5.26.0-RC1 5.25.12 5.25.11 5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
if [[ "${PV##*.}" == "9999" ]]; then
DIST_VERSION=5.26.0-RC1
SHORT_PV="${DIST_VERSION%.*}"
# Devel Releases are not ABI-intercompatible
- SUBSLOT="${DIST_VERSION}"
+ SUBSLOT="${DIST_VERSION%-RC*}"
MY_P="perl-${DIST_VERSION/_rc/-RC}"
- MY_PV="${DIST_VERSION%_rc*}"
+ MY_PV="${DIST_VERSION%-RC*}"
else
# First 2 digits only
SHORT_PV="${PV%.*}"