summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-07-30 11:23:27 -0400
committerMike Gilbert <floppym@gentoo.org>2017-07-30 11:26:29 -0400
commit61958b88555c08f099c70d0b1989b86bcd3f2465 (patch)
tree600f91def11226e5109e7e67d3a7a697780fef01 /dev-lang/python
parentdev-libs/kirigami: Drop old (diff)
downloadgentoo-61958b88555c08f099c70d0b1989b86bcd3f2465.tar.gz
gentoo-61958b88555c08f099c70d0b1989b86bcd3f2465.tar.bz2
gentoo-61958b88555c08f099c70d0b1989b86bcd3f2465.zip
dev-lang/python: fix build failure in blake2 module
Thanks to Johannes Hirte for the simple solution. Bug: https://bugs.gentoo.org/608586 Package-Manager: Portage-2.3.6_p23, Repoman-2.3.3_p1
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/files/3.6-blake2.patch37
-rw-r--r--dev-lang/python/python-3.6.1-r1.ebuild1
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-lang/python/files/3.6-blake2.patch b/dev-lang/python/files/3.6-blake2.patch
new file mode 100644
index 000000000000..48ee58559524
--- /dev/null
+++ b/dev-lang/python/files/3.6-blake2.patch
@@ -0,0 +1,37 @@
+From 2e7c906c085a01ea8175a19e1e143257abc8f566 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sun, 30 Jul 2017 11:17:39 -0400
+Subject: [PATCH] blake2: remove commented code
+
+The nested comments cause a build failure.
+
+Bug: https://bugs.gentoo.org/608586
+---
+ Modules/_blake2/impl/blake2s-load-xop.h | 11 -----------
+ 1 file changed, 11 deletions(-)
+
+diff --git a/Modules/_blake2/impl/blake2s-load-xop.h b/Modules/_blake2/impl/blake2s-load-xop.h
+index a3b5d65e2d..7e76c399c6 100644
+--- a/Modules/_blake2/impl/blake2s-load-xop.h
++++ b/Modules/_blake2/impl/blake2s-load-xop.h
+@@ -18,17 +18,6 @@
+
+ #define TOB(x) ((x)*4*0x01010101 + 0x03020100) /* ..or not TOB */
+
+-/* Basic VPPERM emulation, for testing purposes */
+-/*static __m128i _mm_perm_epi8(const __m128i src1, const __m128i src2, const __m128i sel)
+-{
+- const __m128i sixteen = _mm_set1_epi8(16);
+- const __m128i t0 = _mm_shuffle_epi8(src1, sel);
+- const __m128i s1 = _mm_shuffle_epi8(src2, _mm_sub_epi8(sel, sixteen));
+- const __m128i mask = _mm_or_si128(_mm_cmpeq_epi8(sel, sixteen),
+- _mm_cmpgt_epi8(sel, sixteen)); /* (>=16) = 0xff : 00 */
+- return _mm_blendv_epi8(t0, s1, mask);
+-}*/
+-
+ #define LOAD_MSG_0_1(buf) \
+ buf = _mm_perm_epi8(m0, m1, _mm_set_epi32(TOB(6),TOB(4),TOB(2),TOB(0)) );
+
+--
+2.13.3
+
diff --git a/dev-lang/python/python-3.6.1-r1.ebuild b/dev-lang/python/python-3.6.1-r1.ebuild
index eef0e26c7dc1..ef6e62034cdc 100644
--- a/dev-lang/python/python-3.6.1-r1.ebuild
+++ b/dev-lang/python/python-3.6.1-r1.ebuild
@@ -65,6 +65,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.5-distutils-OO-build.patch"
epatch "${FILESDIR}/3.6.1-test_socket-AEAD.patch"
+ epatch "${FILESDIR}/3.6-blake2.patch"
epatch_user